Skip to content
Laskyr

Plugins · wp-last-modified-info · data as of 2026-11-04

Is WP Last Modified Info safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9.6)

As of 2026-11-04. 4 issues are on record for older versions; version 1.9.6 or newer fixes all of them that state a fix.

Latest version
1.9.6
Last updated
2026-01-30
Active installs
40,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.0+

Ultimate Last Modified Plugin for WordPress with Gutenberg support. Use shortcodes to show last modified info on WP 4.7+ sites. — by Sayan Datta

What to do

  1. Update to the latest version (1.9.6). Anything older than 1.9.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-last-modified-info --field=version shows what you run; wp plugin update wp-last-modified-info updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-14608 · published 2026-02-14

Missing authorization check in WP Last Modified Info (1.9.5 and older)

Affected
1.9.5 and older
Fixed in
1.9.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Last Modified Info plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.9.5. This is due to the plugin not validating a user's access to a post before modifying its metadata in the 'bulk_save' AJAX action. This makes it possible for authenticated attackers, with Author-level access and above, to update the last modified metadata and lock the modification date of arbitrary posts, including those created by Administrators via the 'post_ids' parameter.

NVD CVE-2025-14608Wordfence advisoryCode change (fix)github.comPlugin source

medium 6.5 CVE-2025-62968 · published 2025-10-27

Stored cross-site scripting (XSS) in WP Last Modified Info (1.9.2 and older)

Affected
1.9.2 and older
Fixed in
1.9.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Sayan Datta WP Last Modified Info wp-last-modified-info allows Stored XSS.This issue affects WP Last Modified Info: from n/a through <= 1.9.2.

NVD CVE-2025-62968Patchstack advisory

high 7.4 CVE-2025-52756 · published 2025-10-22

Remote code execution in WP Last Modified Info (1.9.4 and older)

Affected
1.9.4 and older
Fixed in
1.9.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Generation of Code ('Code Injection') vulnerability in Sayan Datta WP Last Modified Info wp-last-modified-info allows Remote Code Inclusion.This issue affects WP Last Modified Info: from n/a through <= 1.9.4.

NVD CVE-2025-52756Patchstack advisory

medium 5.4 CVE-2024-6864 · published 2024-08-20

Stored cross-site scripting (XSS) in WP Last Modified Info (1.9.0 and older)

Affected
1.9.0 and older
Fixed in
1.9.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Last Modified Info plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘template’ attribute of the lmt-post-modified-info shortcode in all versions up to, and including, 1.9.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-6864Wordfence advisoryCode change (fix)wordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Last Modified Info vulnerability status badge
<a href="https://laskyr.com/plugins/wp-last-modified-info"><img src="https://laskyr.com/plugins/wp-last-modified-info/badge.svg" alt="WP Last Modified Info vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit