Skip to content
Laskyr

Plugins · wp-editor · data as of 2026-11-04

Is WP Editor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.9.3)

As of 2026-11-04. 9 issues are on record for older versions; version 1.2.9.3 or newer fixes all of them that state a fix.

Latest version
1.2.9.3
Last updated
2026-03-11
Active installs
20,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
6.9.11

WP Editor is a plugin for WordPress that replaces the default plugin and theme editors as well as the page/post editor. — by benjaminprojas

What to do

  1. Update to the latest version (1.2.9.3). Anything older than 1.2.9.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-editor --field=version shows what you run; wp plugin update wp-editor updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-3772 · published 2026-05-01

Cross-site request forgery (CSRF) in WP Editor (1.2.9.2 and older)

Affected
1.2.9.2 and older
Fixed in
1.2.9.3 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Editor plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.2.9.2. This is due to missing nonce verification in the 'add_plugins_page' and 'add_themes_page' functions. This makes it possible for unauthenticated attackers to overwrite arbitrary plugin and theme PHP files with attacker-controlled code via a forged request, granted they can trick a site administrator into performing an action such as clicking a link.

NVD CVE-2026-3772Wordfence advisoryCode change (fix)Plugin source

medium 4.9 CVE-2025-3295 · published 2025-04-17

Path traversal / file read in WP Editor (1.2.9.1 and older)

Affected
1.2.9.1 and older
Fixed in
1.2.9.2 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Editor plugin for WordPress is vulnerable to arbitrary file read in all versions up to, and including, 1.2.9.1. This makes it possible for authenticated attackers, with Administrator-level access and above, to read arbitrary files on the affected site's server which may reveal sensitive information.

NVD CVE-2025-3295Wordfence advisoryCode change (fix)

high 7.2 CVE-2025-3294 · published 2025-04-17

Remote code execution in WP Editor (1.2.9.1 and older)

Affected
1.2.9.1 and older
Fixed in
1.2.9.2 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Editor plugin for WordPress is vulnerable to arbitrary file update due to missing file path validation in all versions up to, and including, 1.2.9.1. This makes it possible for authenticated attackers, with Administrator-level access and above, to overwrite arbitrary files on the affected site's server which may make remote code execution possible assuming the files can be written to by the web server.

NVD CVE-2025-3294Wordfence advisoryCode change (fix)

high 7.2 CVE-2022-2446 · published 2024-09-13

PHP object injection in WP Editor (1.2.9 and older)

Affected
1.2.9 and older
Fixed in
1.2.9.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Editor plugin for WordPress is vulnerable to deserialization of untrusted input via the 'current_theme_root' parameter in versions up to, and including 1.2.9. This makes it possible for authenticated attackers with administrative privileges to call files using a PHAR wrapper that will deserialize and call arbitrary PHP Objects that can be used to perform a variety of malicious actions granted a POP chain is also present. It also requires that the attacker is successful in uploading a file with the serialized payload.

NVD CVE-2022-2446Wordfence advisoryCode change (fix)

high 7.1 CVE-2024-24700 · published 2024-03-27

Reflected cross-site scripting (XSS) in WP Editor (1.2.8 and older)

Affected
1.2.8 and older
Fixed in
1.2.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Benjamin Rojas WP Editor allows Reflected XSS.This issue affects WP Editor: from n/a through 1.2.8.

NVD CVE-2024-24700Patchstack advisory

high 7.5 CVE-2024-25591 · published 2024-03-17

Information disclosure in WP Editor (1.2.7 and older)

Affected
1.2.7 and older
Fixed in
1.2.8
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Benjamin Rojas WP Editor.This issue affects WP Editor: from n/a through 1.2.7.

NVD CVE-2024-25591Patchstack advisory

high 7.2 CVE-2021-24151 · published 2024-01-16

SQL injection in WP Editor (older than 1.2.7)

Affected
older than 1.2.7
Fixed in
1.2.7
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Editor WordPress plugin before 1.2.7 did not sanitise or validate its setting fields leading to an authenticated (admin+) blind SQL injection issue via an arbitrary parameter when making a request to save the settings.

NVD CVE-2021-24151WPScan advisory

high 8.8 CVE-2016-10885 · published 2019-08-14

Cross-site request forgery (CSRF) in WP Editor (older than 1.2.6)

Affected
older than 1.2.6
Fixed in
1.2.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The wp-editor plugin before 1.2.6 for WordPress has CSRF.

NVD CVE-2016-10885wordpress.org

critical 9.8 CVE-2016-10886 · published 2019-08-14

Security issue in WP Editor (older than 1.2.6)

Affected
older than 1.2.6
Fixed in
1.2.6
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The wp-editor plugin before 1.2.6 for WordPress has incorrect permissions.

NVD CVE-2016-10886wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Editor vulnerability status badge
<a href="https://laskyr.com/plugins/wp-editor"><img src="https://laskyr.com/plugins/wp-editor/badge.svg" alt="WP Editor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit