Plugins · wp-discussion-board · data as of 2026-11-04
Is Discussion Board safe? Known vulnerabilities and latest version
- Latest version
- 2.6.1
- Last updated
- 2026-10-23
- Active installs
- 1,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Discussion Board is a simple, effective way to add a forum or discussion board to your site, helping you build and engage an active community. — by Marketing Fire
What to do
- Update to the latest version (2.6.1). Anything older than 2.6.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-discussion-board --field=version shows what you run; wp plugin update wp-discussion-board updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-107765 · published 2026-10-31
Stored cross-site scripting (XSS) in Discussion Board (2.6.0 and older)
- Affected
- 2.6.0 and older
- Fixed in
- 2.6.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Discussion Board – WordPress Forum Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.6.0 via the user profile Website (user_url) field. This is due to insufficient output escaping in the ctdb_filter_comment_author_name() callback hooked to get_comment_author_link, which interpolates the raw user_url value into a single-quoted href attribute without esc_url() or esc_attr(). This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses a Discussion Board topic containing the attacker's reply.
NVD CVE-2026-107765Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2026-115957 · published 2026-10-28
Stored cross-site scripting (XSS) in Discussion Board (2.6.0 and older)
- Affected
- 2.6.0 and older
- Fixed in
- 2.6.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Discussion Board WP Discussion Board wp-discussion-board allows Stored XSS.This issue affects WP Discussion Board: from n/a through 2.6.0.
medium 5.3 CVE-2026-115958 · published 2026-10-26
Missing authorization check in Discussion Board (2.6.0 and older)
- Affected
- 2.6.0 and older
- Fixed in
- 2.6.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WP Discussion Board WP Discussion Board wp-discussion-board allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Discussion Board: from n/a through 2.6.0.
medium 4.3 CVE-2025-69023 · published 2025-12-30
Missing authorization check in Discussion Board (2.5.7 and older)
- Affected
- 2.5.7 and older
- Fixed in
- 2.5.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Marketing Fire Discussion Board wp-discussion-board allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Discussion Board: from n/a through <= 2.5.7.
medium 6.3 CVE-2025-8483 · published 2025-10-25
Remote code execution in Discussion Board (2.5.5 and older)
- Affected
- 2.5.5 and older
- Fixed in
- 2.5.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The The Discussion Board – WordPress Forum Plugin plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.5.5. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with Subscriber-level access and above, to execute arbitrary shortcodes.
medium 5.4 CVE-2023-39161 · published 2024-06-04
Cross-site scripting (XSS) in Discussion Board (2.4.8 and older)
- Affected
- 2.4.8 and older
- Fixed in
- 2.4.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in WP Discussion Board Discussion Board allows Content Spoofing, Cross-Site Scripting (XSS).This issue affects Discussion Board: from n/a through 2.4.8.
Recent activity
- 2026-10-23 — latest release on wordpress.org (2.6.1).
- 2026-10-31 — Stored cross-site scripting (XSS) disclosed (CVE-2026-107765), fixed in 2.6.1.
- 2026-10-28 — Stored cross-site scripting (XSS) disclosed (CVE-2026-115957), fixed in 2.6.1.
- 2026-10-26 — Missing authorization check disclosed (CVE-2026-115958), fixed in 2.6.1.
Get an email when Discussion Board has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Discussion Board (wp-discussion-board) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Marketing Fire (3 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Missing authorization (2) · Remote code execution (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-discussion-board (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-discussion-board"><img src="https://laskyr.com/plugins/wp-discussion-board/badge.svg" alt="Discussion Board vulnerability status"></a>