Skip to content
Laskyr

Plugins · wordpress-popular-posts · data as of 2026-11-04

Is WP Popular Posts safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (7.4.4)

As of 2026-11-04. 7 issues are on record for older versions; version 7.4.3 or newer fixes all of them that state a fix.

Latest version
7.4.4
Last updated
2026-11-02
Active installs
100,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

A highly customizable, easy-to-use popular posts plugin! — by Hector Cabrera

What to do

  1. Update to the latest version (7.4.4). Anything older than 7.4.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wordpress-popular-posts --field=version shows what you run; wp plugin update wordpress-popular-posts updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-92548 · published 2026-10-01

Information disclosure in WP Popular Posts (7.4.2 and older)

Affected
7.4.2 and older
Fixed in
7.4.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Popular Posts plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 7.4.2 via the 'context' parameter. This makes it possible for unauthenticated attackers to extract sensitive edit-context fields — including raw title, raw content body, password, meta, status, and guid — from non-public post objects such as wp_block synced patterns that WordPress core itself refuses to expose to unauthenticated callers. This is possible because the plugin's REST route is registered with a permission_callback of __return_true and passes the caller-supplied context parameter (e.g., context=edit) directly to WP_REST_Posts_Controller::prepare_item_for_response() without invoking get_item_permissions_check() or check_read_permission(), while the underlying query accepts an arbitrary post_type value without enforcing public or show_in_rest visibility flags.

NVD CVE-2026-92548Wordfence advisoryCode change (fix)Plugin source

high 7.3 CVE-2024-11733 · published 2025-01-03

Remote code execution in WP Popular Posts (7.1.0 and older)

Affected
7.1.0 and older
Fixed in
7.2.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The The WordPress Popular Posts plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 7.1.0. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.

NVD CVE-2024-11733Wordfence advisoryPlugin source

medium 5.4 CVE-2023-45607 · published 2023-10-18

Stored cross-site scripting (XSS) in WP Popular Posts (6.3.2 and older)

Affected
6.3.2 and older
Fixed in
6.3.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in Hector Cabrera WordPress Popular Posts plugin <= 6.3.2 versions.

NVD CVE-2023-45607Patchstack advisory

high 7.5 CVE-2022-43468 · published 2022-12-07

Security issue in WP Popular Posts (6.0.5 and older)

Affected
6.0.5 and older
Fixed in
6.1.0 *
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

External initialization of trusted variables or data stores vulnerability exists in WordPress Popular Posts 6.0.5 and earlier, therefore the vulnerable product accepts untrusted external inputs to update certain internal variables. As a result, the number of views for an article may be manipulated through a crafted input.

NVD CVE-2022-43468wordpress.orggithub.comjvn.jp

high 8.8 CVE-2021-42362 · published 2021-11-17

Arbitrary file upload in WP Popular Posts (0.0 to 5.3.2)

Affected
0.0 to 5.3.2
Fixed in
5.3.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WordPress Popular Posts WordPress plugin is vulnerable to arbitrary file uploads due to insufficient input file type validation found in the ~/src/Image.php file which makes it possible for attackers with contributor level access and above to upload malicious files that can be used to obtain remote code execution, in versions up to and including 5.3.2.

NVD CVE-2021-42362WPScan advisoryCode change (fix)packetstormsecurity.comblog.nintechnet.comgithub.comWordfence advisory

medium 5.4 CVE-2021-36872 · published 2021-09-23

Cross-site scripting (XSS) in WP Popular Posts (5.3.3 to 5.3.3)

Affected
5.3.3 to 5.3.3
Fixed in
5.3.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Authenticated Persistent Cross-Site Scripting (XSS) vulnerability in WordPress Popular Posts plugin (versions <= 5.3.3). Vulnerable at &widget-wpp[2][post_type].

NVD CVE-2021-36872Patchstack advisorygithub.com

medium 5.4 CVE-2021-20746 · published 2021-06-28

Cross-site scripting (XSS) in WP Popular Posts (5.3.2 and older)

Affected
5.3.2 and older
Fixed in
5.3.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

Cross-site scripting vulnerability in WordPress Popular Posts 5.3.2 and earlier allows a remote authenticated attacker to inject an arbitrary script via unspecified vectors.

NVD CVE-2021-20746wordpress.orgcabrerahector.comcabrerahector.comjvn.jp

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Popular Posts vulnerability status badge
<a href="https://laskyr.com/plugins/wordpress-popular-posts"><img src="https://laskyr.com/plugins/wordpress-popular-posts/badge.svg" alt="WP Popular Posts vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit