Plugins · woocommerce-germanized · data as of 2026-11-04
Is Germanized for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 4.1.6
- Last updated
- 2026-10-20
- Active installs
- 70,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Germanized extends WooCommerce to become a legally compliant shop for the german market. Must Have for every german WooCommerce shop owner. — by vendidero
What to do
- Update to the latest version (4.1.6). Anything older than 4.1.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woocommerce-germanized --field=version shows what you run; wp plugin update woocommerce-germanized updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-109231 · published 2026-10-31
Security issue in Germanized for WooCommerce (4.1.4 and older)
- Affected
- 4.1.4 and older
- Fixed in
- 4.1.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Germanized for WooCommerce plugin for WordPress is vulnerable to Unauthorized Access of Private Data via Activation Token Reuse in versions up to, and including, 4.1.4. This is due to the `on_user_email_changed` hook — which is responsible for rotating the activation token and recording a pending-email-change marker on an unactivated Customer account — only being registered inside the `is_double_opt_in_login_enabled()` branch when "Disable login for unactivated customers" is set to Yes, leaving the original `?activate=` token valid and entirely unbound to the email address it was issued for when that setting is No. This makes it possible for authenticated attackers, with Subscriber-level access and above, to change their account email to a victim's billing email via the standard `/my-account/edit-account/` form and then redeem their original activation token through `customer_account_activate()`, triggering `link_customer_past_orders()` to reassign any matching guest order to the attacker's account and exposing the original buyer's billing name, street address, phone number, and purchased items on the attacker's My Account order page. Exploitation requires the site to have double opt-in enabled with "Disable login for unactivated customers" explicitly set to No (a non-default configuration), public customer registration enabled, and the original activation token redeemed within its one-day expiry window.
NVD CVE-2026-109231Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2026-2582 · published 2026-04-14
Remote code execution in Germanized for WooCommerce (3.20.5 and older)
- Affected
- 3.20.5 and older
- Fixed in
- 3.20.6 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The The Germanized for WooCommerce plugin for WordPress is vulnerable to arbitrary shortcode execution via 'account_holder' parameter in all versions up to, and including, 3.20.5. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
Recent activity
- 2026-10-20 — latest release on wordpress.org (4.1.6).
- 2026-10-31 — Security issue disclosed (CVE-2026-109231), fixed in 4.1.5.
- 2026-04-14 — Remote code execution disclosed (CVE-2026-2582), fixed in 3.20.6.
Get an email when Germanized for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Germanized for WooCommerce (woocommerce-germanized) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by vendidero (3 tracked)
Types found in this plugin: Remote code execution (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woocommerce-germanized (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woocommerce-germanized"><img src="https://laskyr.com/plugins/woocommerce-germanized/badge.svg" alt="Germanized for WooCommerce vulnerability status"></a>