Skip to content
Laskyr

Plugins · woocommerce-eu-vat-assistant · data as of 2026-11-04

Is EU VAT Assistant for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.0.261001)

As of 2026-11-04. 1 issue is on record for older versions; version 2.2.0.261001 or newer fixes all of them that state a fix.

Latest version
2.2.0.261001
Last updated
2026-10-05
Active installs
5,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.9 · PHP 7.1+

Extends the standard WooCommerce sale process and assists in achieving compliance with the new EU VAT regime starting on the 1st of January 2015. — by Diego

What to do

  1. Update to the latest version (2.2.0.261001). Anything older than 2.2.0.261001 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woocommerce-eu-vat-assistant --field=version shows what you run; wp plugin update woocommerce-eu-vat-assistant updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-103899 · published 2026-10-17

Stored cross-site scripting (XSS) in EU VAT Assistant for WooCommerce (2.1.30.260413 and older)

Affected
2.1.30.260413 and older
Fixed in
2.2.0.261001 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The EU VAT Assistant for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'vat_number' parameter in all versions up to, and including, 2.1.30.260413 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The stored payload executes in the administrator's browser context when reviewing an order via WooCommerce → Orders → Edit Order, enabling privilege escalation up to and including full site takeover via rogue administrator account creation.

NVD CVE-2026-103899Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
EU VAT Assistant for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woocommerce-eu-vat-assistant"><img src="https://laskyr.com/plugins/woocommerce-eu-vat-assistant/badge.svg" alt="EU VAT Assistant for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit