Skip to content
Laskyr

CVE-2026-103899: EU VAT Assistant for WooCommerce stored cross-site scripting (XSS) vulnerability

high 7.2 published 2026-10-17 · updated 2026-10-19

Fixed in EU VAT Assistant for WooCommerce 2.2.0.261001 (first release after the affected range)

EU VAT Assistant for WooCommerce 2.1.30.260413 and older is affected by this stored XSS issue. Sites on 2.2.0.261001 or newer are not affected; the latest release is 2.2.0.261001.

Affected versions
2.1.30.260413 and older
Fixed in
2.2.0.261001 *
Latest version
2.2.0.261001
Severity
High · CVSS 7.2
Active installs
5,000+
Type
Stored cross-site scripting (XSS)

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

What to do now

  1. Update EU VAT Assistant for WooCommerce to 2.2.0.261001 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known EU VAT Assistant for WooCommerce issue. With WP-CLI: wp plugin get woocommerce-eu-vat-assistant --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The EU VAT Assistant for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'vat_number' parameter in all versions up to, and including, 2.1.30.260413 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The stored payload executes in the administrator's browser context when reviewing an order via WooCommerce → Orders → Edit Order, enabling privilege escalation up to and including full site takeover via rogue administrator account creation.

Description from the CVE record, published by Wordfence (the CVE Numbering Authority), via the NVD entry for CVE-2026-103899.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit