Skip to content
Laskyr

Plugins · woo-refund-and-exchange-lite · data as of 2026-11-04

Is Return Refund and Exchange For WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.6.5)

As of 2026-11-04. 7 issues are on record for older versions; version 4.6.5 or newer fixes all of them that state a fix.

Latest version
4.6.5
Last updated
2026-10-23
Active installs
4,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Provide an easy refund service and increase customer satisfaction with WooCommerce Return Refund, and Exchange Warranty Management Plugin. — by WP Swings

What to do

  1. Update to the latest version (4.6.5). Anything older than 4.6.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-refund-and-exchange-lite --field=version shows what you run; wp plugin update woo-refund-and-exchange-lite updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-81799 · published 2026-09-10

Missing authorization check in Return Refund and Exchange For WooCommerce (4.6.4 and older)

Affected
4.6.4 and older
Fixed in
4.6.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WP Swings Return Refund and Exchange For WooCommerce woo-refund-and-exchange-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Return Refund and Exchange For WooCommerce: from n/a through 4.6.4.

NVD CVE-2026-81799Patchstack advisory

medium 6.5 CVE-2026-77695 · published 2026-08-26

Missing authorization check in Return Refund and Exchange For WooCommerce (4.4.6 up to (not including) 4.6.4)

Affected
4.4.6 up to (not including) 4.6.4
Fixed in
4.6.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Return Refund and Exchange For WooCommerce WordPress plugin before 4.6.4 does not correctly verify the ownership of guest orders in some of the AJAX actions it exposes to unauthenticated users, allowing them to read private order messages, post messages and attachments in the customer's name, and cancel return requests on any guest order.

NVD CVE-2026-77695WPScan advisory

medium 5.4 CVE-2025-12881 · published 2025-11-21

Missing authorization check in Return Refund and Exchange For WooCommerce (4.5.5 and older)

Affected
4.5.5 and older
Fixed in
4.5.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Return Refund and Exchange For WooCommerce plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 4.5.5 via the wps_rma_fetch_order_msgs() due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read other user's order messages.

NVD CVE-2025-12881Wordfence advisoryCode change (fix)

medium 4.3 CVE-2025-12086 · published 2025-11-21

Missing authorization check in Return Refund and Exchange For WooCommerce (4.5.5 and older)

Affected
4.5.5 and older
Fixed in
4.5.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Return Refund and Exchange For WooCommerce plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 4.5.5 via the 'wps_rma_cancel_return_request' AJAX endpoint due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete other users refund requests.

NVD CVE-2025-12086Wordfence advisoryCode change (fix)

medium 5.4 CVE-2024-13692 · published 2025-02-14

Missing authorization check in Return Refund and Exchange For WooCommerce (4.4.5 and older)

Affected
4.4.5 and older
Fixed in
4.4.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Return Refund and Exchange For WooCommerce – Return Management System, RMA Exchange, Wallet And Cancel Order Features plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 4.4.5 via several functions due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to overwrite linked refund image attachments, overwrite refund request message, overwrite order messages, and read order messages of other users.

NVD CVE-2024-13692Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2024-13641 · published 2025-02-14

Information disclosure in Return Refund and Exchange For WooCommerce (4.4.5 and older)

Affected
4.4.5 and older
Fixed in
4.4.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Return Refund and Exchange For WooCommerce – Return Management System, RMA Exchange, Wallet And Cancel Order Features plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.4.5 via the 'attachment' directory. This makes it possible for unauthenticated attackers to extract sensitive data stored insecurely in the /wp-content/attachment directory which can contain file attachments for order refunds.

NVD CVE-2024-13641Wordfence advisoryCode change (fix)Plugin source

critical 9.8 CVE-2022-4047 · published 2022-12-26

Remote code execution in Return Refund and Exchange For WooCommerce (older than 4.0.9)

Affected
older than 4.0.9
Fixed in
4.0.9
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Return Refund and Exchange For WooCommerce WordPress plugin before 4.0.9 does not validate attachment files to be uploaded via an AJAX action available to unauthenticated users, which could allow them to upload arbitrary files such as PHP and lead to RCE

NVD CVE-2022-4047WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Return Refund and Exchange For WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woo-refund-and-exchange-lite"><img src="https://laskyr.com/plugins/woo-refund-and-exchange-lite/badge.svg" alt="Return Refund and Exchange For WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit