Skip to content
Laskyr

Plugins · woo-multi-currency · data as of 2026-11-04

Is CURCY safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.20)

As of 2026-11-04. 8 issues are on record for older versions; version 2.2.18 or newer fixes all of them that state a fix.

Latest version
2.2.20
Last updated
2026-10-29
Active installs
20,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Show multi-currency pricing and dual-currency display, accept multi-currency payment, support IP detection, custom/global rate, fixed price and more — by VillaTheme

What to do

  1. Update to the latest version (2.2.20). Anything older than 2.2.18 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-multi-currency --field=version shows what you run; wp plugin update woo-multi-currency updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-97071 · published 2026-10-05

Security issue in CURCY (2.2.17 and older)

Affected
2.2.17 and older
Fixed in
2.2.18
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Calculation vulnerability in VillaTheme CURCY woo-multi-currency allows Integer Attacks.This issue affects CURCY: from n/a through 2.2.17.

NVD CVE-2026-97071Patchstack advisory

high 7.1 CVE-2026-94171 · published 2026-09-30

Cross-site scripting (XSS) in CURCY (0.0.0 to 2.2.16, 2.2.18 only)

Affected
0.0.0 to 2.2.16, 2.2.18 only
Fixed in
2.2.17
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in VillaTheme CURCY woo-multi-currency allows DOM-Based XSS.This issue affects CURCY: 2.2.18.

NVD CVE-2026-94171Patchstack advisory

medium 5.4 CVE-2026-11778 · published 2026-07-03

Remote code execution in CURCY (2.2.14 and older)

Affected
2.2.14 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The The CURCY – Multi Currency for WooCommerce – Smoothly on WooCommerce 9.x plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.2.14. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.

NVD CVE-2026-11778Wordfence advisoryPlugin source

high 7.3 CVE-2024-13487 · published 2025-02-06

Remote code execution in CURCY (2.2.5 and older)

Affected
2.2.5 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The The CURCY – Multi Currency for WooCommerce – The best free currency exchange plugin – Run smoothly on WooCommerce 9.x plugin for WordPress is vulnerable to arbitrary shortcode execution via the get_products_price() function in all versions up to, and including, 2.2.5. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.

NVD CVE-2024-13487Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 6.5 CVE-2022-46796 · published 2024-12-13

Missing authorization check in CURCY (2.1.25 and older)

Affected
2.1.25 and older
Fixed in
2.1.26
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in VillaTheme CURCY allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects CURCY: from n/a through 2.1.25.

NVD CVE-2022-46796Patchstack advisory

high 7.1 CVE-2024-49283 · published 2024-10-17

Reflected cross-site scripting (XSS) in CURCY (2.2.3 and older)

Affected
2.2.3 and older
Fixed in
2.2.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in VillaTheme CURCY woo-multi-currency allows Reflected XSS.This issue affects CURCY: from n/a through <= 2.2.3.

NVD CVE-2024-49283Patchstack advisory

medium 5.4 CVE-2023-50831 · published 2023-12-21

Stored cross-site scripting (XSS) in CURCY (2.2.0 and older)

Affected
2.2.0 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in VillaTheme CURCY – Multi Currency for WooCommerce allows Stored XSS.This issue affects CURCY – Multi Currency for WooCommerce: from n/a through 2.2.0.

NVD CVE-2023-50831Patchstack advisory

medium 4.3 CVE-2021-4376 · published 2023-06-07

Missing authorization check in CURCY (2.1.17 and older)

Affected
2.1.17 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WooCommerce Multi Currency plugin for WordPress is vulnerable to Missing Authorization in versions up to, and including, 2.1.17. This makes it possible for authenticated attackers to change the price of a product to an arbitrary value.

NVD CVE-2021-4376Wordfence advisoryWPScan advisoryCode change (fix)wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CURCY vulnerability status badge
<a href="https://laskyr.com/plugins/woo-multi-currency"><img src="https://laskyr.com/plugins/woo-multi-currency/badge.svg" alt="CURCY vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit