Skip to content
Laskyr

Plugins · woo-lucky-wheel · data as of 2026-11-04

Is Lucky Wheel for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.3)

As of 2026-11-04. 1 issue is on record for older versions.

Latest version
1.2.3
Last updated
2026-09-26
Active installs
1,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Engage customers with a fun spin-the-wheel game! Collect emails and reward them with discount coupons instantly. — by VillaTheme

What to do

  1. Update to the latest version (1.2.3). Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-lucky-wheel --field=version shows what you run; wp plugin update woo-lucky-wheel updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2025-14509 · published 2025-12-30

Remote code execution in Lucky Wheel for WooCommerce (1.1.13 and older)

Affected
1.1.13 and older
Fixed in
unknown
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Lucky Wheel for WooCommerce – Spin a Sale plugin for WordPress is vulnerable to PHP Code Injection in all versions up to, and including, 1.1.13. This is due to the plugin using eval() to execute user-supplied input from the 'Conditional Tags' setting without proper validation or sanitization. This makes it possible for authenticated attackers, with Administrator-level access and above, to execute arbitrary PHP code on the server. In WordPress multisite installations, this allows Site Administrators to execute arbitrary code, a capability they should not have since plugin/theme file editing is disabled for non-Super Admins in multisite environments.

NVD CVE-2025-14509Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Lucky Wheel for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woo-lucky-wheel"><img src="https://laskyr.com/plugins/woo-lucky-wheel/badge.svg" alt="Lucky Wheel for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit