Skip to content
Laskyr

Plugins · woo-custom-product-addons · data as of 2026-11-04

Is Product Addons for Woocommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.9)

As of 2026-11-04. 2 issues are on record for older versions; version 3.1.9 or newer fixes all of them that state a fix.

Latest version
3.1.9
Last updated
2026-10-20
Active installs
30,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

WooCommerce Product Addons Add custom fields to your WooCommerce product page. With an easy-to-use Custom Form Builder. — by acowebs

What to do

  1. Update to the latest version (3.1.9). Anything older than 3.1.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get woo-custom-product-addons --field=version shows what you run; wp plugin update woo-custom-product-addons updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-109988 · published 2026-10-28

Stored cross-site scripting (XSS) in Product Addons for Woocommerce (3.1.8 and older)

Affected
3.1.8 and older
Fixed in
3.1.9 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Product Addons for Woocommerce – Product Options with Custom Fields plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'fields[section][fields][row][col][type]' parameter in all versions up to, and including, 3.1.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with shop manager-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-109988Wordfence advisoryCode change (fix)wordpress.orgPlugin source

high 7.2 CVE-2026-2296 · published 2026-02-18

Remote code execution in Product Addons for Woocommerce (3.1.0 and older)

Affected
3.1.0 and older
Fixed in
3.1.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Product Addons for Woocommerce – Product Options with Custom Fields plugin for WordPress is vulnerable to Code Injection in all versions up to, and including, 3.1.0. This is due to insufficient input validation of the 'operator' field in conditional logic rules within the evalConditions() function, which passes unsanitized user input directly to PHP's eval() function. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to inject and execute arbitrary PHP code on the server via the conditional logic 'operator' parameter when saving addon form field rules.

NVD CVE-2026-2296Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Product Addons for Woocommerce vulnerability status badge
<a href="https://laskyr.com/plugins/woo-custom-product-addons"><img src="https://laskyr.com/plugins/woo-custom-product-addons/badge.svg" alt="Product Addons for Woocommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit