Plugins · woo-cart-all-in-one · data as of 2026-11-04
Is CartSuite safe? Known vulnerabilities and latest version
- Latest version
- 1.1.26
- Last updated
- 2026-08-22
- Active installs
- 5,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Cart All In One For WooCommerce helps your customers view cart effortlessly. — by VillaTheme
What to do
- Update to the latest version (1.1.26). Anything older than 1.1.11 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get woo-cart-all-in-one --field=version shows what you run; wp plugin update woo-cart-all-in-one updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-2019 · published 2026-02-18
Remote code execution in CartSuite (1.1.21 and older)
- Affected
- 1.1.21 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Cart All In One For WooCommerce plugin for WordPress is vulnerable to Code Injection in all versions up to, and including, 1.1.21. This is due to insufficient input validation on the 'Assign page' field which is passed directly to the eval() function. This makes it possible for authenticated attackers, with Administrator-level access and above, to execute arbitrary PHP code on the server.
NVD CVE-2026-2019Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2022-46806 · published 2023-03-01
Cross-site request forgery (CSRF) in CartSuite (1.1.10 and older)
- Affected
- 1.1.10 and older
- Fixed in
- 1.1.11
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in VillaTheme Cart All In One For WooCommerce plugin <= 1.1.10 leading to cart modification.
Recent activity
- 2026-08-22 — latest release on wordpress.org (1.1.26).
- 2026-02-18 — Remote code execution disclosed (CVE-2026-2019), fix version not stated.
- 2023-03-01 — Cross-site request forgery (CSRF) disclosed (CVE-2022-46806), fixed in 1.1.11.
Get an email when CartSuite has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for CartSuite (woo-cart-all-in-one) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by VillaTheme (25 tracked)
Types found in this plugin: Remote code execution (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/woo-cart-all-in-one (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/woo-cart-all-in-one"><img src="https://laskyr.com/plugins/woo-cart-all-in-one/badge.svg" alt="CartSuite vulnerability status"></a>