Plugins · widget-wrangler · data as of 2026-11-04
Is Widget Wrangler safe? Known vulnerabilities and latest version
- Status
- Closed 2026-04-11
- Known issues on record
- 1
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate widget-wrangler && wp plugin delete widget-wrangler
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 1 record(s) do not state which versions are affected.
critical 9.1 CVE-2026-25447 · published 2026-03-25
Remote code execution in Widget Wrangler (2.3.9 and older)
- Affected
- 2.3.9 and older
- Fixed in
- 2.4.0
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Generation of Code ('Code Injection') vulnerability in Jonathan Daggerhart Widget Wrangler widget-wrangler allows Code Injection.This issue affects Widget Wrangler: from n/a through <= 2.3.9.
Recent activity
- 2026-04-11 — closed on wordpress.org (Author Request).
- 2026-03-25 — Remote code execution disclosed (CVE-2026-25447), fixed in 2.4.0.
Get an email when Widget Wrangler has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Widget Wrangler (widget-wrangler) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Remote code execution (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/widget-wrangler (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/widget-wrangler"><img src="https://laskyr.com/plugins/widget-wrangler/badge.svg" alt="Widget Wrangler vulnerability status"></a>