Plugins · widget-logic · data as of 2026-11-04
Is Widget Logic safe? Known vulnerabilities and latest version
- Status
- Closed 2026-04-14
- Known issues on record
- 2
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate widget-logic && wp plugin delete widget-logic
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 2 record(s) do not state which versions are affected.
critical 9.9 CVE-2025-32222 · published 2025-11-06
Remote code execution in Widget Logic (6.0.5 and older)
- Affected
- 6.0.5 and older
- Fixed in
- 6.0.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Generation of Code ('Code Injection') vulnerability in Widgetlogic.org Widget Logic widget-logic allows Code Injection.This issue affects Widget Logic: from n/a through <= 6.0.5.
high 8.8 CVE-2019-12826 · published 2019-07-01
Cross-site request forgery (CSRF) in Widget Logic (older than 5.10.2)
- Affected
- older than 5.10.2
- Fixed in
- 5.10.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
A Cross-Site-Request-Forgery (CSRF) vulnerability in widget_logic.php in the 2by2host Widget Logic plugin before 5.10.2 for WordPress allows remote attackers to execute PHP code via snippets (that are attached to widgets and then eval'd to dynamically determine their visibility) by crafting a malicious POST request that tricks administrators into adding the code.
NVD CVE-2019-12826Code change (fix)dannewitz.ninjawpvulndb.comwpvulndb.com
Recent activity
- 2026-04-14 — closed on wordpress.org (Guideline Violation).
- 2025-11-06 — Remote code execution disclosed (CVE-2025-32222), fixed in 6.0.6.
- 2019-07-01 — Cross-site request forgery (CSRF) disclosed (CVE-2019-12826), fixed in 5.10.2.
Get an email when Widget Logic has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Widget Logic (widget-logic) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Remote code execution (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/widget-logic (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/widget-logic"><img src="https://laskyr.com/plugins/widget-logic/badge.svg" alt="Widget Logic vulnerability status"></a>