Plugins · wholesalex · data as of 2026-11-04
Is WholesaleX safe? Known vulnerabilities and latest version
- Latest version
- 3.1.8
- Last updated
- 2026-11-02
- Active installs
- 2,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
All-in-one WooCommerce wholesale solution with wholesale pricing, B2B user roles, registration form and private store. — by WPXPO
What to do
- Update to the latest version (3.1.8). Anything older than 3.0.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wholesalex --field=version shows what you run; wp plugin update wholesalex updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-111955 · published 2026-10-21
Authentication bypass in WholesaleX (older than 3.0.9)
- Affected
- older than 3.0.9
- Fixed in
- 3.0.9
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The WholesaleX WordPress plugin before 3.0.9 does not check that a stored account confirmation code is set before comparing it with the one supplied in a request, allowing unauthenticated users to activate pending accounts and bypass the administrator approval required before login.
medium 5.9 CVE-2026-111956 · published 2026-10-21
Information disclosure in WholesaleX (older than 3.0.9)
- Affected
- older than 3.0.9
- Fixed in
- 3.0.9
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The WholesaleX WordPress plugin before 3.0.9 does not protect or remove the user-import file it keeps in a publicly accessible location under a predictable name, allowing unauthenticated users to download the most recently imported user data, including any account passwords and customer contact and address details it contains.
medium 5.4 CVE-2026-8145 · published 2026-10-15
Privilege escalation in WholesaleX (3.0.8 and older)
- Affected
- 3.0.8 and older
- Fixed in
- 3.0.9 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WholesaleX – B2B & Wholesale Plugin for WooCommerce with Wholesale Prices plugin for WordPress is vulnerable to Limited Privilege Escalation in all versions up to, and including, 3.0.8 via the 'process_registration' due to missing validation on the 'wholesalex_registration_role' parameter. This makes it possible for unauthenticated attackers to register as any existing WholesaleX role. The vulnerability was partially patched in version 2.3.8.
NVD CVE-2026-8145Wordfence advisoryCode change (fix)Plugin source
critical 9.8 CVE-2024-30542 · published 2024-05-17
Privilege escalation in WholesaleX (1.3.2 and older)
- Affected
- 1.3.2 and older
- Fixed in
- 1.3.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Privilege Management vulnerability in Wholesale WholesaleX allows Privilege Escalation.This issue affects WholesaleX: from n/a through 1.3.2.
critical 9.8 CVE-2024-30224 · published 2024-03-28
PHP object injection in WholesaleX (1.3.2 and older)
- Affected
- 1.3.2 and older
- Fixed in
- 1.3.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Deserialization of Untrusted Data vulnerability in Wholesale Team WholesaleX.This issue affects WholesaleX: from n/a through 1.3.2.
medium 6.5 CVE-2024-30233 · published 2024-03-26
Information disclosure in WholesaleX (1.3.1 and older)
- Affected
- 1.3.1 and older
- Fixed in
- 1.3.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wholesale Team WholesaleX.This issue affects WholesaleX: from n/a through 1.3.1.
high 8.8 CVE-2024-30234 · published 2024-03-26
Missing authorization check in WholesaleX (1.3.1 and older)
- Affected
- 1.3.1 and older
- Fixed in
- 1.3.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Missing Authorization vulnerability in Wholesale Team WholesaleX.This issue affects WholesaleX: from n/a through 1.3.1.
Recent activity
- 2026-11-02 — latest release on wordpress.org (3.1.8).
- 2026-10-21 — Authentication bypass disclosed (CVE-2026-111955), fixed in 3.0.9.
- 2026-10-21 — Information disclosure disclosed (CVE-2026-111956), fixed in 3.0.9.
- 2026-10-15 — Privilege escalation disclosed (CVE-2026-8145), fixed in 3.0.9.
Get an email when WholesaleX has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WholesaleX (wholesalex) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by WPXPO (2 tracked)
Types found in this plugin: Sensitive data exposure (2) · Privilege escalation (2) · Authentication bypass (1) · PHP object injection (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wholesalex (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wholesalex"><img src="https://laskyr.com/plugins/wholesalex/badge.svg" alt="WholesaleX vulnerability status"></a>