Skip to content
Laskyr

CVE-2026-111955: WholesaleX authentication bypass vulnerability

medium 6.5 published 2026-10-21

Fixed in WholesaleX 3.0.9

WholesaleX older than 3.0.9 is affected by this authentication bypass issue. Sites on 3.0.9 or newer are not affected; the latest release is 3.1.8.

Affected versions
older than 3.0.9
Fixed in
3.0.9
Latest version
3.1.8
Severity
Medium · CVSS 6.5
Active installs
2,000+
Type
Authentication bypass

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

What to do now

  1. Update WholesaleX to 3.0.9 or newer (the latest is 3.1.8): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known WholesaleX issue. With WP-CLI: wp plugin get wholesalex --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The WholesaleX WordPress plugin before 3.0.9 does not check that a stored account confirmation code is set before comparing it with the one supplied in a request, allowing unauthenticated users to activate pending accounts and bypass the administrator approval required before login.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-111955.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit