Skip to content
Laskyr

Plugins · wc-carta-docente · data as of 2026-11-04

Is ilGhera Carta Docente for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.7)

As of 2026-11-04. 1 issue is on record for older versions; version 1.5.1 or newer fixes all of them that state a fix.

Latest version
1.5.7
Last updated
2026-10-15
Active installs
200+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4

Abilita in WooCommerce il pagamento con Carta del Docente. — by ilGhera

What to do

  1. Update to the latest version (1.5.7). Anything older than 1.5.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wc-carta-docente --field=version shows what you run; wp plugin update wc-carta-docente updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-2421 · published 2026-03-20

Remote code execution in ilGhera Carta Docente for WooCommerce (1.5.0 and older)

Affected
1.5.0 and older
Fixed in
1.5.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ilGhera Carta Docente for WooCommerce plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.5.0 via the 'cert' parameter of the 'wccd-delete-certificate' AJAX action. This is due to insufficient file path validation before performing a file deletion. This makes it possible for authenticated attackers, with Administrator-level access and above, to delete arbitrary files on the server, such as wp-config.php, which can make site takeover and remote code execution possible.

NVD CVE-2026-2421Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ilGhera Carta Docente for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/wc-carta-docente"><img src="https://laskyr.com/plugins/wc-carta-docente/badge.svg" alt="ilGhera Carta Docente for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit