Skip to content
Laskyr

Plugins · user-private-files · data as of 2026-11-04

Is User Private Files safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.2)

As of 2026-11-04. 6 issues are on record for older versions; version 2.2.0 or newer fixes all of them that state a fix.

Latest version
2.2.2
Last updated
2026-11-03
Active installs
1,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

A secure file share plugin for WordPress. Securely upload, manage and exchange private documents with site users. — by Deepak Khokhar

What to do

  1. Update to the latest version (2.2.2). Anything older than 2.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get user-private-files --field=version shows what you run; wp plugin update user-private-files updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-97331 · published 2026-10-07

Information disclosure in User Private Files (older than 2.1.9)

Affected
older than 2.1.9
Fixed in
2.1.9
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The User Private Files WordPress plugin before 2.1.9 does not validate that a supplied user belongs to the document being operated on before returning that user's email address, allowing any authenticated user, such as a Subscriber, to obtain the email address of any registered account, including administrators.

NVD CVE-2026-97331WPScan advisory

medium 5.3 CVE-2026-97332 · published 2026-10-04

Missing authorization check in User Private Files (older than 2.2.0)

Affected
older than 2.2.0
Fixed in
2.2.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The User Private Files WordPress plugin before 2.2.0 does not properly protect its stored private files on multisite installations, where the rewrite rule it relies on to route file requests through its access check is never reached, allowing unauthenticated users to retrieve other users' private files directly.

NVD CVE-2026-97332WPScan advisorygithub.com

medium 6.4 CVE-2026-10093 · published 2026-06-16

Stored cross-site scripting (XSS) in User Private Files (2.1.6 and older)

Affected
2.1.6 and older
Fixed in
2.1.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The File Sharing & Download Manager – User Private Files plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'fldr_ttl' parameter in all versions up to, and including, 2.1.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-10093Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2024-13799 · published 2025-02-19

Stored cross-site scripting (XSS) in User Private Files (2.1.3 and older)

Affected
2.1.3 and older
Fixed in
2.1.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The User Private Files – File Upload & Download Manager with Secure File Sharing plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘new-fldr-name’ parameter in all versions up to, and including, 2.1.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-13799Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2024-7848 · published 2024-08-22

Missing authorization check in User Private Files (2.1.0 and older)

Affected
2.1.0 and older
Fixed in
2.1.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The User Private Files – WordPress File Sharing Plugin plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 2.1.0 via the 'dpk_upvf_update_doc' due to missing validation on the 'docid' user controlled key. This makes it possible for authenticated attackers, with subscriber-level access and above, to gain access to other user's private files.

NVD CVE-2024-7848Wordfence advisoryCode change (fix)

medium 4.8 CVE-2023-4636 · published 2023-09-05

Stored cross-site scripting (XSS) in User Private Files (2.0.3 and older)

Affected
2.0.3 and older
Fixed in
2.0.4 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WordPress File Sharing Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in versions up to, and including, 2.0.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2023-4636Wordfence advisoryCode change (fix)github.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
User Private Files vulnerability status badge
<a href="https://laskyr.com/plugins/user-private-files"><img src="https://laskyr.com/plugins/user-private-files/badge.svg" alt="User Private Files vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit