Skip to content
Laskyr

CVE-2026-97331: User Private Files information disclosure vulnerability

medium 4.3 published 2026-10-07

Fixed in User Private Files 2.1.9

User Private Files older than 2.1.9 is affected by this information disclosure issue. Sites on 2.1.9 or newer are not affected; the latest release is 2.2.2.

Affected versions
older than 2.1.9
Fixed in
2.1.9
Latest version
2.2.2
Severity
Medium · CVSS 4.3
Active installs
1,000+
Type
Information disclosure

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

What to do now

  1. Update User Private Files to 2.1.9 or newer (the latest is 2.2.2): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known User Private Files issue. With WP-CLI: wp plugin get user-private-files --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The User Private Files WordPress plugin before 2.1.9 does not validate that a supplied user belongs to the document being operated on before returning that user's email address, allowing any authenticated user, such as a Subscriber, to obtain the email address of any registered account, including administrators.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-97331.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit