Skip to content
Laskyr

Plugins · ultimate-multisite · data as of 2026-11-04

Is Ultimate Multisite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.18.0)

As of 2026-11-04. 3 issues are on record for older versions; version 2.17.2 or newer fixes all of them that state a fix.

Latest version
2.18.0
Last updated
2026-10-28
Active installs
100+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

Ultimate Multisite turns your WordPress network into a WaaS platform with subscriptions, site provisioning, and domain mapping. — by David Stone

What to do

  1. Update to the latest version (2.18.0). Anything older than 2.17.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ultimate-multisite --field=version shows what you run; wp plugin update ultimate-multisite updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.6 CVE-2026-107508 · published 2026-10-14

Path traversal / file read in Ultimate Multisite (older than 2.17.2)

Affected
older than 2.17.2
Fixed in
2.17.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Ultimate Multisite WordPress plugin before 2.17.2 does not validate a user-supplied value used to select a file to include, allowing unauthenticated attackers to include and read arbitrary local files, including the WordPress configuration file.

NVD CVE-2026-107508WPScan advisory

critical 9.8 CVE-2026-103646 · published 2026-10-08

Authentication bypass in Ultimate Multisite (older than 2.17.0)

Affected
older than 2.17.0
Fixed in
2.17.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Ultimate Multisite WordPress plugin before 2.17.0 does not require authentication before a logged-out checkout is linked to, and logged in as, an existing WordPress account matching the submitted email address, and its duplicate-account check normalizes that address differently from the lookup used to create the customer, so an unauthenticated attacker can log in as any existing user, including a Network Super Admin, whose email address they know. This bypass is not addressed by the 2.15.1 fix for CVE-2026-75957 and remains exploitable in all versions up to and including 2.16.1, the releases that fix was expected to cover. Exploitation requires a checkout form configured without a password field (auto-generated password) and a target account that has no existing customer record in the Ultimate Multisite WordPress plugin before 2.17.0.

NVD CVE-2026-103646WPScan advisory

critical 9.8 CVE-2026-75957 · published 2026-10-01

Authentication bypass in Ultimate Multisite (2.15.0 and older)

Affected
2.15.0 and older
Fixed in
2.15.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Ultimate Multisite – WordPress Multisite SaaS & WaaS Platform plugin for WordPress is vulnerable to Authentication Bypass in all versions up to, and including, 2.15.0 via the `checkout_form` parameter of the `login_customer_after_checkout` function. This is due to the publicly accessible `wu_ajax_nopriv_wu_validate_form` AJAX handler accepting a freely obtainable checkout nonce, and the `checkout_form=wu-finish-checkout` parameter causing `get_validation_rules()` to discard all validation rules while `finish_checkout_form_fields()` returns an empty step list — forcing `is_last_step()` to return true and routing the request directly into full order processing — after which `maybe_create_customer()` resolves the attacker-supplied `email_address` to an existing WordPress user ID without any authentication or ownership verification, and `login_customer_after_checkout()` calls `wp_set_auth_cookie()` for that user ID via a passwordless code path. This makes it possible for unauthenticated attackers to log in as any existing WordPress user — including a Network Super Admin — simply by knowing their email address. Exploitation requires that the targeted user account has no pre-existing Ultimate Multisite customer record; accounts such as a Network Super Admin on a fresh Multisite install, or any administrator or editor added before Ultimate Multisite was configured, satisfy this condition and are therefore exploitable.

NVD CVE-2026-75957Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Ultimate Multisite vulnerability status badge
<a href="https://laskyr.com/plugins/ultimate-multisite"><img src="https://laskyr.com/plugins/ultimate-multisite/badge.svg" alt="Ultimate Multisite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit