Skip to content
Laskyr

CVE-2026-107508: Ultimate Multisite path traversal / file read vulnerability

high 8.6 published 2026-10-14

Fixed in Ultimate Multisite 2.17.2

Ultimate Multisite older than 2.17.2 is affected by this path traversal issue. Sites on 2.17.2 or newer are not affected; the latest release is 2.18.0.

Affected versions
older than 2.17.2
Fixed in
2.17.2
Latest version
2.18.0
Severity
High · CVSS 8.6
Active installs
100+
Type
Path traversal / file read

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

What to do now

  1. Update Ultimate Multisite to 2.17.2 or newer (the latest is 2.18.0): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Ultimate Multisite issue. With WP-CLI: wp plugin get ultimate-multisite --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Ultimate Multisite WordPress plugin before 2.17.2 does not validate a user-supplied value used to select a file to include, allowing unauthenticated attackers to include and read arbitrary local files, including the WordPress configuration file.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-107508.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit