Plugins · tlp-food-menu · data as of 2026-11-04
Is Food Menu safe? Known vulnerabilities and latest version
- Latest version
- 6.0.7
- Last updated
- 2026-10-25
- Active installs
- 2,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Restaurant menu plugin for WordPress with food menu display, online food ordering, free table reservation, tips and WooCommerce. — by RadiusTheme
What to do
- Update to the latest version (6.0.7). Anything older than 6.0.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get tlp-food-menu --field=version shows what you run; wp plugin update tlp-food-menu updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-42709 · published 2026-10-10
Cross-site scripting (XSS) in Food Menu (6.0.5 and older)
- Affected
- 6.0.5 and older
- Fixed in
- 6.0.6 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Food Menu – Restaurant Menu & Online Ordering for WooCommerce <= 6.0.5 versions.
medium 5.3 CVE-2026-13328 · published 2026-08-13
Missing authorization check in Food Menu (older than 6.0.2)
- Affected
- older than 6.0.2
- Fixed in
- 6.0.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Food Menu WordPress plugin before 6.0.2 does not perform any capability or ownership check on its reservation-status update action, which is also exposed to unauthenticated users and gated only by a nonce that is publicly available to visitors, allowing unauthenticated attackers to change the status of arbitrary reservations.
medium 4.3 CVE-2024-13415 · published 2025-01-31
Missing authorization check in Food Menu (5.1.4 and older)
- Affected
- 5.1.4 and older
- Fixed in
- 5.2.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Food Menu – Restaurant Menu & Online Ordering for WooCommerce plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the response() function in all versions up to, and including, 5.1.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to modify the plugin's settings.
NVD CVE-2024-13415Wordfence advisoryCode change (fix)plugins.svn.wordpress.org
Recent activity
- 2026-10-25 — latest release on wordpress.org (6.0.7).
- 2026-10-10 — Cross-site scripting (XSS) disclosed (CVE-2026-42709), fixed in 6.0.6.
- 2026-08-13 — Missing authorization check disclosed (CVE-2026-13328), fixed in 6.0.2.
- 2025-01-31 — Missing authorization check disclosed (CVE-2024-13415), fixed in 5.2.0.
Get an email when Food Menu has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Food Menu (tlp-food-menu) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by RadiusTheme (7 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/tlp-food-menu (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/tlp-food-menu"><img src="https://laskyr.com/plugins/tlp-food-menu/badge.svg" alt="Food Menu vulnerability status"></a>