Skip to content
Laskyr

CVE-2026-42709: Food Menu cross-site scripting (XSS) vulnerability

high 7.1 published 2026-10-10 · updated 2026-10-13

Fixed in Food Menu 6.0.6 (first release after the affected range)

Food Menu 6.0.5 and older is affected by this XSS issue. Sites on 6.0.6 or newer are not affected; the latest release is 6.0.7.

Affected versions
6.0.5 and older
Fixed in
6.0.6 *
Latest version
6.0.7
Severity
High · CVSS 7.1
Active installs
2,000+
Type
Cross-site scripting (XSS)

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

What to do now

  1. Update Food Menu to 6.0.6 or newer (the latest is 6.0.7): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Food Menu issue. With WP-CLI: wp plugin get tlp-food-menu --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Unauthenticated Cross Site Scripting (XSS) in Food Menu – Restaurant Menu & Online Ordering for WooCommerce <= 6.0.5 versions.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-42709.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit