Plugins · thesis-openhook · data as of 2026-11-04
Is OpenHook safe? Known vulnerabilities and latest version
- Latest version
- 4.3.1
- Last updated
- 2023-09-29
- Active installs
- 1,000+
- Known issues on record
- 2
- Unpatched in latest
- 1
- Tested up to WP
- 6.3.14
Add customizations to any hook in WordPress and any hook-enabled theme or plugin from within your admin panel! Wanna play hooky? — by Rick Beckman
What to do
- There is no fixed version yet. If you can live without OpenHook for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get thesis-openhook --field=version shows what you run; wp plugin update thesis-openhook updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 affects latest 4.3.1 CVE-2025-62120 · published 2025-12-31
Cross-site request forgery (CSRF) in OpenHook (4.3.1 and older)
- Affected
- 4.3.1 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Rick Beckman OpenHook thesis-openhook allows Cross Site Request Forgery.This issue affects OpenHook: from n/a through <= 4.3.1.
high 8.8 CVE-2023-5201 · published 2023-09-30
Remote code execution in OpenHook (4.3.0 and older)
- Affected
- 4.3.0 and older
- Fixed in
- 4.3.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The OpenHook plugin for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 4.3.0 via the 'php' shortcode. This allows authenticated attackers with subscriber-level permissions or above, to execute code on the server. This requires the [php] shortcode setting to be enabled on the vulnerable site.
Recent activity
- 2023-09-29 — latest release on wordpress.org (4.3.1).
- 2025-12-31 — Cross-site request forgery (CSRF) disclosed (CVE-2025-62120), no fix listed yet.
- 2023-09-30 — Remote code execution disclosed (CVE-2023-5201), fixed in 4.3.1.
Get an email when OpenHook has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for OpenHook (thesis-openhook) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (1) · Remote code execution (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/thesis-openhook (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/thesis-openhook"><img src="https://laskyr.com/plugins/thesis-openhook/badge.svg" alt="OpenHook vulnerability status"></a>