Skip to content
Laskyr

Plugins · the-welcomizer · data as of 2026-11-04

Is The Welcomizer safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (999.0)

As of 2026-11-04. 1 issue is on record for older versions; version 999.0 or newer fixes all of them that state a fix.

Latest version
999.0
Last updated
2026-03-17
Active installs
20+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
4.2.39

This plugin allows you to quickly animate your WordPress blog. — by sebwordpress

What to do

  1. Update to the latest version (999.0). Anything older than 999.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get the-welcomizer --field=version shows what you run; wp plugin update the-welcomizer updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-4327 · published 2026-09-19

Remote code execution in The Welcomizer (2.8.1 and older)

Affected
2.8.1 and older
Fixed in
999.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The The Welcomizer plugin for WordPress is vulnerable to Remote Code Execution in all versions up to and including 2.8.1. This is due to missing authorization checks on the twiz_ajax_callback AJAX action's 'savesection' handler combined with the use of eval() to execute user-supplied 'custom logic' code on the frontend. The AJAX handler at twiz-ajax.php verifies a nonce but performs no current_user_can() capability check for the ACTION_SAVE_SECTION case. Furthermore, the nonce is exposed to any authenticated user through the directly-accessible twiz-ajax.js.php file which loads WordPress and outputs the nonce. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary PHP code via the twiz_custom_logic POST parameter when saving a section with output choice 'twiz_logic_output'.

NVD CVE-2026-4327Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
The Welcomizer vulnerability status badge
<a href="https://laskyr.com/plugins/the-welcomizer"><img src="https://laskyr.com/plugins/the-welcomizer/badge.svg" alt="The Welcomizer vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit