Skip to content
Laskyr

Plugins · squeeze · data as of 2026-11-04

Is Squeeze safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8.3.1)

As of 2026-11-04. 6 issues are on record for older versions; version 1.8.1 or newer fixes all of them that state a fix.

Latest version
1.8.3.1
Last updated
2026-11-03
Active installs
3,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Browser-based image compression & WebP—no API keys or quotas. Works on any hosting. — by Bogdan Bendziukov · Pluginarium

What to do

  1. Update to the latest version (1.8.3.1). Anything older than 1.8.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get squeeze --field=version shows what you run; wp plugin update squeeze updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-110029 · published 2026-10-16

Missing authorization check in Squeeze (older than 1.8.1)

Affected
older than 1.8.1
Fixed in
1.8.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by WPScan
Details from the advisory

The Squeeze WordPress plugin before 1.8.1 does not perform a capability check on one of its AJAX actions, allowing authenticated users with a role as low as Subscriber to revert any attachment to its backup copy and to permanently delete that backup and the plugin's generated WebP derivatives, regardless of ownership.

NVD CVE-2026-110029WPScan advisory

high 8.8 CVE-2026-16985 · published 2026-08-10

Remote code execution in Squeeze (older than 1.7.12)

Affected
older than 1.7.12
Fixed in
1.7.12
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Squeeze WordPress plugin before 1.7.12 does not validate the file type or extension of the per-size image data written by one of its attachment-update actions, allowing users with the upload_files capability (Author and above) to write an executable PHP file into the uploads directory and achieve remote code execution.

NVD CVE-2026-16985WPScan advisory

medium 5.0 CVE-2026-32415 · published 2026-03-13

Path traversal / file read in Squeeze (1.7.7 and older)

Affected
1.7.7 and older
Fixed in
1.7.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Path Traversal: '.../...//' vulnerability in Bogdan Bendziukov Squeeze squeeze allows Path Traversal.This issue affects Squeeze: from n/a through <= 1.7.7.

NVD CVE-2026-32415Patchstack advisory

critical 9.1 CVE-2025-31002 · published 2025-04-09

Arbitrary file upload in Squeeze (1.6 and older)

Affected
1.6 and older
Fixed in
1.6.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in Bogdan Bendziukov Squeeze squeeze allows Using Malicious Files.This issue affects Squeeze: from n/a through <= 1.6.

NVD CVE-2025-31002Patchstack advisory

low 2.7 CVE-2025-31003 · published 2025-04-09

Information disclosure in Squeeze (1.6 and older)

Affected
1.6 and older
Fixed in
1.6.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in Bogdan Bendziukov Squeeze squeeze allows Retrieve Embedded Sensitive Data.This issue affects Squeeze: from n/a through <= 1.6.

NVD CVE-2025-31003Patchstack advisory

high 7.2 CVE-2024-35767 · published 2024-06-21

Arbitrary file upload in Squeeze (1.4 and older)

Affected
1.4 and older
Fixed in
1.4.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in Bogdan Bendziukov Squeeze allows Code Injection.This issue affects Squeeze: from n/a through 1.4.

NVD CVE-2024-35767Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Squeeze vulnerability status badge
<a href="https://laskyr.com/plugins/squeeze"><img src="https://laskyr.com/plugins/squeeze/badge.svg" alt="Squeeze vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit