Skip to content
Laskyr

Plugins · slim-seo · data as of 2026-11-04

Is Slim SEO safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.11.4)

As of 2026-11-04. 7 issues are on record for older versions; version 4.11.2 or newer fixes all of them that state a fix.

Latest version
4.11.4
Last updated
2026-10-20
Active installs
70,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

An AI SEO plugin for WordPress that's lightweight and fast. Automatically generates meta tags, sitemaps, schemas and more with no bloat. — by Anh Tran

What to do

  1. Update to the latest version (4.11.4). Anything older than 4.11.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get slim-seo --field=version shows what you run; wp plugin update slim-seo updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-104001 · published 2026-10-16

Remote code execution in Slim SEO (4.11.1 and older)

Affected
4.11.1 and older
Fixed in
4.11.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The The Slim SEO – AI SEO Plugin, Lightweight, Fast & Automated plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 4.11.1 This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with subscriber-level access and above, to execute arbitrary shortcodes. A Subscriber-level user need only save the shortcode payload to their own Biographical Info field via the REST API or wp-admin profile page; the shortcode then executes on any unauthenticated front-end request that resolves that author's description, such as requests using the ?author= query parameter when auto_redirection is disabled.

NVD CVE-2026-104001Wordfence advisoryCode change (fix)github.comPlugin source

medium 4.3 CVE-2026-62113 · published 2026-09-11

Missing authorization check in Slim SEO (4.10.0 and older)

Affected
4.10.0 and older
Fixed in
4.10.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Insecure Direct Object References (IDOR) in Slim SEO <= 4.10.0 versions.

NVD CVE-2026-62113Patchstack advisory

low 2.7 CVE-2026-16957 · published 2026-08-09

Missing authorization check in Slim SEO (older than 4.9.11)

Affected
older than 4.9.11
Fixed in
4.9.11
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Slim SEO WordPress plugin before 4.9.11 does not restrict a post-meta preview feature to posts the user is allowed to edit, verifying only read access, allowing users with the Contributor role to read arbitrary post meta, including protected and private keys, of published posts they do not own, including password-protected posts and posts of non-public post types.

NVD CVE-2026-16957WPScan advisory

medium 4.3 CVE-2026-12408 · published 2026-07-01

Information disclosure in Slim SEO (4.9.8 and older)

Affected
4.9.8 and older
Fixed in
4.9.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Slim SEO – A Fast & Automated SEO Plugin For WordPress plugin for WordPress is vulnerable to Unauthorized Private Content Disclosure in all versions up to, and including, 4.9.8 via the `/wp-json/slim-seo/meta-tags/ai` REST API endpoint. This is due to the endpoint's `permission_callback` performing only a top-level `edit_posts` capability check without verifying that the requesting user has read access to the specific post supplied via the `object.ID` parameter, allowing the `generate` function to pass the attacker-controlled post ID to `Data::get_post_content()`, which calls `get_post()` regardless of post status or ownership. This makes it possible for authenticated attackers with Contributor-level access and above to retrieve AI-generated summaries of the raw `post_content` of arbitrary posts they are not authorized to view — including private posts, drafts, pending, future, and password-protected content authored by other users — with the substance of the protected content disclosed via the HTTP response.

NVD CVE-2026-12408Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2026-57429 · published 2026-06-25

Missing authorization check in Slim SEO (4.6.2 and older)

Affected
4.6.2 and older
Fixed in
4.7.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Broken Access Control in Slim SEO <= 4.6.2 versions.

NVD CVE-2026-57429Patchstack advisory

high 7.6 CVE-2025-49854 · published 2025-06-17

SQL injection in Slim SEO (4.5.4 and older)

Affected
4.5.4 and older
Fixed in
4.5.5
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Anh Tran Slim SEO slim-seo allows SQL Injection.This issue affects Slim SEO: from n/a through <= 4.5.4.

NVD CVE-2025-49854Patchstack advisory

medium 6.4 CVE-2025-4611 · published 2025-05-21

Stored cross-site scripting (XSS) in Slim SEO (4.5.3 and older)

Affected
4.5.3 and older
Fixed in
4.5.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Slim SEO – Fast & Automated WordPress SEO Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's slim_seo_breadcrumbs shortcode in all versions up to, and including, 4.5.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-4611Wordfence advisoryCode change (fix)wordpress.orggithub.comPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Slim SEO vulnerability status badge
<a href="https://laskyr.com/plugins/slim-seo"><img src="https://laskyr.com/plugins/slim-seo/badge.svg" alt="Slim SEO vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit