Skip to content
Laskyr

Plugins · siteskite · data as of 2026-11-04

Is SiteSkite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.12)

As of 2026-11-04. 3 issues are on record for older versions; version 2.2.0 or newer fixes all of them that state a fix.

Latest version
2.2.12
Last updated
2026-10-29
Active installs
200+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Secure WordPress MCP for Claude and ChatGPT, AI Studio and full WebOps, Backups, Sandbox & Fleet Control. — by SiteSkite

What to do

  1. Update to the latest version (2.2.12). Anything older than 2.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get siteskite --field=version shows what you run; wp plugin update siteskite updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 10.0 CVE-2026-96349 · published 2026-09-30

Remote code execution in SiteSkite (2.1.8 and older)

Affected
2.1.8 and older
Fixed in
2.2.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Remote Code Execution (RCE) in SiteSkite <= 2.1.8 versions.

NVD CVE-2026-96349Patchstack advisory

medium 4.3 CVE-2026-93513 · published 2026-09-23

Missing authorization check in SiteSkite (2.1.7 and older)

Affected
2.1.7 and older
Fixed in
2.1.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Insecure Direct Object References (IDOR) in SiteSkite <= 2.1.7 versions.

NVD CVE-2026-93513Patchstack advisory

high 8.1 CVE-2026-81805 · published 2026-09-10

Privilege escalation in SiteSkite (2.1.5 and older)

Affected
2.1.5 and older
Fixed in
2.1.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Privilege Escalation in SiteSkite <= 2.1.5 versions.

NVD CVE-2026-81805Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
SiteSkite vulnerability status badge
<a href="https://laskyr.com/plugins/siteskite"><img src="https://laskyr.com/plugins/siteskite/badge.svg" alt="SiteSkite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit