Skip to content
Laskyr

Plugins · simple-link-directory · data as of 2026-11-04

Is Simple Link Directory safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (9.2.2)

As of 2026-11-04. 6 issues are on record for older versions; version 8.9.4 or newer fixes all of them that state a fix.

Latest version
9.2.2
Last updated
2026-10-07
Active installs
2,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

AI Powered LINK DIRECTORY Plugin for WordPress to Curate Links for Web Directory. Link Management, Directory Listings, Link Archive, Vendor Directory — by QuantumCloud

What to do

  1. Update to the latest version (9.2.2). Anything older than 8.9.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get simple-link-directory --field=version shows what you run; wp plugin update simple-link-directory updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-7209 · published 2026-05-02

Stored cross-site scripting (XSS) in Simple Link Directory (8.9.2 and older)

Affected
8.9.2 and older
Fixed in
8.9.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Simple Link Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's `qcopd-directory` shortcode in all versions up to, and including, 8.9.2. This is due to insufficient input sanitization and output escaping on user supplied attributes such as `title_font_size`. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-7209Wordfence advisorywordpress.orgPlugin source

medium 5.3 CVE-2025-67576 · published 2025-12-09

Missing authorization check in Simple Link Directory (8.8.3 and older)

Affected
8.8.3 and older
Fixed in
8.8.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in QuantumCloud Simple Link Directory simple-link-directory allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Simple Link Directory: from n/a through <= 8.8.3.

NVD CVE-2025-67576Patchstack advisory

medium 4.3 CVE-2025-67465 · published 2025-12-09

Cross-site request forgery (CSRF) in Simple Link Directory (8.8.3 and older)

Affected
8.8.3 and older
Fixed in
8.8.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in QuantumCloud Simple Link Directory simple-link-directory allows Cross Site Request Forgery.This issue affects Simple Link Directory: from n/a through <= 8.8.3.

NVD CVE-2025-67465Patchstack advisory

medium 6.5 CVE-2024-12417 · published 2024-12-13

Remote code execution in Simple Link Directory (8.4.5 and older)

Affected
8.4.5 and older
Fixed in
8.4.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The The Simple Link Directory plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 8.4.5. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.

NVD CVE-2024-12417Wordfence advisoryCode change (fix)Plugin source

critical 9.8 CVE-2022-0760 · published 2022-03-21

SQL injection in Simple Link Directory (older than 7.7.2)

Affected
older than 7.7.2
Fixed in
7.7.2
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The Simple Link Directory WordPress plugin before 7.7.2 does not validate and escape the post_id parameter before using it in a SQL statement via the qcopd_upvote_action AJAX action (available to unauthenticated and authenticated users), leading to an unauthenticated SQL Injection

NVD CVE-2022-0760WPScan advisoryCode change (fix)

medium 6.1 CVE-2019-13463 · published 2020-03-20

Cross-site scripting (XSS) in Simple Link Directory (older than 7.3.5)

Affected
older than 7.3.5
Fixed in
7.3.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

An XSS vulnerability in qcopd-shortcode-generator.php in the Simple Link Directory plugin before 7.3.5 for WordPress allows remote attackers to inject arbitrary web script or HTML, because esc_html is not called for the "echo get_the_title()" or "echo $term->name" statement.

NVD CVE-2019-13463Code change (fix)wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Simple Link Directory vulnerability status badge
<a href="https://laskyr.com/plugins/simple-link-directory"><img src="https://laskyr.com/plugins/simple-link-directory/badge.svg" alt="Simple Link Directory vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit