Plugins · simple-jwt-login · data as of 2026-11-04
Is Simple JWT Login safe? Known vulnerabilities and latest version
- Latest version
- 3.6.8
- Last updated
- 2026-08-09
- Active installs
- 4,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 5.5+
Enhance the WordPress REST API with JWT authentication for secure access by mobile apps, external sites, and third-party services. — by Nicu Micle
What to do
- Update to the latest version (3.6.8). Anything older than 4.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get simple-jwt-login --field=version shows what you run; wp plugin update simple-jwt-login updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.8 CVE-2026-39793 · published 2026-10-06
Authentication bypass in Simple JWT Login (4.0.0 only)
- Affected
- 4.0.0 only
- Fixed in
- 4.0.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Broken Authentication in Simple JWT Login 4.0.0 versions.
critical 9.1 CVE-2026-19714 · published 2026-08-16
Authentication bypass in Simple JWT Login (older than 3.6.8)
- Affected
- older than 3.6.8
- Fixed in
- 3.6.8
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Simple JWT Login WordPress plugin before 3.6.8 does not validate the audience of the Google identity tokens it accepts, allowing unauthenticated users to authenticate as any user whose email address such a token carries, up to and including an administrator. Every site with the Simple JWT Login WordPress plugin before 3.6.8's Google sign-in enabled is affected.
high 8.8 CVE-2026-14262 · published 2026-07-11
Privilege escalation in Simple JWT Login (3.6.6 and older)
- Affected
- 3.6.6 and older
- Fixed in
- 3.6.7 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Simple JWT Login – Allows you to use JWT on REST endpoints. plugin for WordPress is vulnerable to Authentication Bypass to Privilege Escalation in all versions up to, and including, 3.6.6 via the `payload` parameter. The vulnerability exists because `AuthenticateService::generatePayload()` only overwrites JWT payload keys whose names appear in the admin-configured `jwt_payload` list — leaving any attacker-supplied identity claims such as `email`, `id`, or `username` intact and signed into the JWT with the site's HS256 secret. This makes it possible for authenticated attackers, with subscriber-level access and above, to escalate their privileges to that of an Administrator by injecting a target administrator's email address into the `payload` parameter at the `/wp-json/simple-jwt-login/v1/auth` endpoint, then redeeming the resulting JWT at the `/autologin` endpoint to obtain a fully authenticated session as that administrator.
NVD CVE-2026-14262Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2025-58648 · published 2025-09-22
Stored cross-site scripting (XSS) in Simple JWT Login (3.6.4 and older)
- Affected
- 3.6.4 and older
- Fixed in
- 3.6.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Nicu Micle Simple JWT Login simple-jwt-login allows Stored XSS.This issue affects Simple JWT Login: from n/a through <= 3.6.4.
high 7.5 CVE-2021-24998 · published 2021-12-27
Weak randomness in Simple JWT Login (older than 3.3.0)
- Affected
- older than 3.3.0
- Fixed in
- 3.3.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Simple JWT Login WordPress plugin before 3.3.0 can be used to create new WordPress user accounts with a randomly generated password. The password is generated using the str_shuffle PHP function that "does not generate cryptographically secure values, and should not be used for cryptographic purposes" according to PHP's documentation.
high 8.8 CVE-2021-24804 · published 2021-11-17
Cross-site request forgery (CSRF) in Simple JWT Login (older than 3.2.1)
- Affected
- older than 3.2.1
- Fixed in
- 3.2.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Simple JWT Login WordPress plugin before 3.2.1 does not have nonce checks when saving its settings, allowing attackers to make a logged in admin changed them. Settings such as HMAC verification secret, account registering and default user roles can be updated, which could result in site takeover.
Recent activity
- 2026-08-09 — latest release on wordpress.org (3.6.8).
- 2026-10-06 — Authentication bypass disclosed (CVE-2026-39793), fixed in 4.0.1.
- 2026-08-16 — Authentication bypass disclosed (CVE-2026-19714), fixed in 3.6.8.
- 2026-07-11 — Privilege escalation disclosed (CVE-2026-14262), fixed in 3.6.7.
Get an email when Simple JWT Login has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Simple JWT Login (simple-jwt-login) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Authentication bypass (2) · Privilege escalation (1) · Cross-site scripting (XSS) (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/simple-jwt-login (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/simple-jwt-login"><img src="https://laskyr.com/plugins/simple-jwt-login/badge.svg" alt="Simple JWT Login vulnerability status"></a>