Skip to content
Laskyr

Plugins · sign-up-sheets · data as of 2026-11-04

Is Sign-up Sheets safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.1)

As of 2026-11-04. 10 issues are on record for older versions; version 2.4.0 or newer fixes all of them that state a fix.

Latest version
2.4.1
Last updated
2026-10-31
Active installs
1,000+
Known issues on record
10
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Create online sign-up sheets for volunteers, events, and group scheduling. — by Fetch Designs

What to do

  1. Update to the latest version (2.4.1). Anything older than 2.4.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get sign-up-sheets --field=version shows what you run; wp plugin update sign-up-sheets updates it.

Check your version

Known vulnerabilities

10 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-92410 · published 2026-09-20

Cross-site request forgery (CSRF) in Sign-up Sheets (older than 2.4.0)

Affected
older than 2.4.0
Fixed in
2.4.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Sign-up Sheets WordPress plugin before 2.4.0 does not properly validate the CSRF nonce that protects its sign-up deletion action, allowing attackers to delete sign-up records via a forged request handled in the session of a logged-in user with the required capability.

NVD CVE-2026-92410WPScan advisory

critical 9.8 CVE-2025-49393 · published 2025-11-06

PHP object injection in Sign-up Sheets (2.3.2 and older)

Affected
2.3.2 and older
Fixed in
2.3.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in Fetch Designs Sign-up Sheets sign-up-sheets allows Object Injection.This issue affects Sign-up Sheets: from n/a through <= 2.3.2.

NVD CVE-2025-49393Patchstack advisory

medium 4.3 CVE-2025-49391 · published 2025-08-20

Cross-site request forgery (CSRF) in Sign-up Sheets (2.3.3 and older)

Affected
2.3.3 and older
Fixed in
2.3.3.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Fetch Designs Sign-up Sheets sign-up-sheets allows Cross Site Request Forgery.This issue affects Sign-up Sheets: from n/a through <= 2.3.3.

NVD CVE-2025-49391Patchstack advisory

medium 6.5 CVE-2025-26996 · published 2025-04-15

Remote code execution in Sign-up Sheets (2.3.0.1 and older)

Affected
2.3.0.1 and older
Fixed in
2.3.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Generation of Code ('Code Injection') vulnerability in Fetch Designs Sign-up Sheets sign-up-sheets allows Code Injection.This issue affects Sign-up Sheets: from n/a through <= 2.3.0.1.

NVD CVE-2025-26996Patchstack advisory

medium 5.3 CVE-2024-39654 · published 2024-11-01

Missing authorization check in Sign-up Sheets (2.2.12 and older)

Affected
2.2.12 and older
Fixed in
2.2.13
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Fetch Designs Sign-up Sheets sign-up-sheets.This issue affects Sign-up Sheets: from n/a through <= 2.2.12.

NVD CVE-2024-39654Patchstack advisory

medium 6.1 CVE-2024-6020 · published 2024-09-04

Reflected cross-site scripting (XSS) in Sign-up Sheets (older than 2.2.13)

Affected
older than 2.2.13
Fixed in
2.2.13
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Sign-up Sheets WordPress plugin before 2.2.13 does not escape some generated URLs, as well as the $_SERVER['REQUEST_URI'] parameter before outputting them back in attributes, which could lead to Reflected Cross-Site Scripting.

NVD CVE-2024-6020WPScan advisory

medium 4.3 CVE-2024-31303 · published 2024-04-12

Cross-site request forgery (CSRF) in Sign-up Sheets (2.2.11.1 and older)

Affected
2.2.11.1 and older
Fixed in
2.2.12
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Fetch Designs Sign-up Sheets sign-up-sheets.This issue affects Sign-up Sheets: from n/a through <= 2.2.11.1.

NVD CVE-2024-31303Patchstack advisoryPatchstack advisory

high 8.8 CVE-2023-39165 · published 2023-10-03

Cross-site request forgery (CSRF) in Sign-up Sheets (2.2.8 and older)

Affected
2.2.8 and older
Fixed in
2.2.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Fetch Designs Sign-up Sheets plugin <= 2.2.8 versions.

NVD CVE-2023-39165Patchstack advisory

medium 4.8 CVE-2021-24440 · published 2021-07-12

Stored cross-site scripting (XSS) in Sign-up Sheets (older than 1.0.14)

Affected
older than 1.0.14
Fixed in
1.0.14
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The Sign-up Sheets WordPress plugin before 1.0.14 did not sanitise or escape some of its fields when creating a new sheet, allowing high privilege users to add JavaScript in them, leading to a Stored Cross-Site Scripting issue. The payloads will be triggered when viewing the 'All Sheets' page in the admin dashboard

NVD CVE-2021-24440WPScan advisory

high 8.0 CVE-2021-24441 · published 2021-07-12

CSV injection in Sign-up Sheets (older than 1.0.14)

Affected
older than 1.0.14
Fixed in
1.0.14
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The Sign-up Sheets WordPress plugin before 1.0.14 does not not sanitise or validate the Sheet title when generating the CSV to export, which could lead to a CSV injection issue

NVD CVE-2021-24441WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Sign-up Sheets vulnerability status badge
<a href="https://laskyr.com/plugins/sign-up-sheets"><img src="https://laskyr.com/plugins/sign-up-sheets/badge.svg" alt="Sign-up Sheets vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit