Skip to content
Laskyr

Plugins · shopmagic-for-woocommerce · data as of 2026-11-04

Is ShopMagic safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.9.3)

As of 2026-11-04. 4 issues are on record for older versions; version 4.9.2 or newer fixes all of them that state a fix.

Latest version
4.9.3
Last updated
2026-10-22
Active installs
10,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Flexible email automation and workflows triggered by customer and site events. — by wpdesk

What to do

  1. Update to the latest version (4.9.3). Anything older than 4.9.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get shopmagic-for-woocommerce --field=version shows what you run; wp plugin update shopmagic-for-woocommerce updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-114195 · published 2026-10-22

Information disclosure in ShopMagic (4.9.1 and older)

Affected
4.9.1 and older
Fixed in
4.9.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information into Externally-Accessible File or Directory vulnerability in WP Desk ShopMagic shopmagic-for-woocommerce allows Retrieve Embedded Sensitive Data.This issue affects ShopMagic: from n/a through 4.9.1.

NVD CVE-2026-114195Patchstack advisory

high 8.1 CVE-2026-103367 · published 2026-10-14

File inclusion in ShopMagic (4.9.0 and older)

Affected
4.9.0 and older
Fixed in
4.9.1-beta.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ShopMagic – email automation for WordPress plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 4.9.0 via the 'billing_address.first_name' parameter parameter. This makes it possible for unauthenticated attackers to include and execute arbitrary .php files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where .php file types can be uploaded and included. Exploitation requires a published recipe that processes the {{ customer.first_name }} placeholder — the plugin's built-in "New Order email with social media profile links" recipe satisfies this requirement out of the box, making the default configuration exploitable with no account, cookie, or nonce by simply submitting a guest checkout with the payload as the billing first name.

NVD CVE-2026-103367Wordfence advisoryPlugin source

medium 5.3 CVE-2025-69093 · published 2025-12-30

Missing authorization check in ShopMagic (4.7.2 and older)

Affected
4.7.2 and older
Fixed in
4.7.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in wpdesk ShopMagic shopmagic-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects ShopMagic: from n/a through <= 4.7.2.

NVD CVE-2025-69093Patchstack advisory

medium 5.8 CVE-2025-59578 · published 2025-10-22

Information disclosure in ShopMagic (4.5.6 and older)

Affected
4.5.6 and older
Fixed in
4.5.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in wpdesk ShopMagic shopmagic-for-woocommerce allows Retrieve Embedded Sensitive Data.This issue affects ShopMagic: from n/a through <= 4.5.6.

NVD CVE-2025-59578Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ShopMagic vulnerability status badge
<a href="https://laskyr.com/plugins/shopmagic-for-woocommerce"><img src="https://laskyr.com/plugins/shopmagic-for-woocommerce/badge.svg" alt="ShopMagic vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit