Skip to content
Laskyr

CVE-2026-114195: ShopMagic information disclosure vulnerability

medium 5.3 published 2026-10-22

Fixed in ShopMagic 4.9.2

ShopMagic 4.9.1 and older is affected by this information disclosure issue. Sites on 4.9.2 or newer are not affected; the latest release is 4.9.3.

Affected versions
4.9.1 and older
Fixed in
4.9.2
Latest version
4.9.3
Severity
Medium · CVSS 5.3
Active installs
10,000+
Type
Information disclosure

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

What to do now

  1. Update ShopMagic to 4.9.2 or newer (the latest is 4.9.3): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known ShopMagic issue. With WP-CLI: wp plugin get shopmagic-for-woocommerce --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Insertion of Sensitive Information into Externally-Accessible File or Directory vulnerability in WP Desk ShopMagic shopmagic-for-woocommerce allows Retrieve Embedded Sensitive Data.This issue affects ShopMagic: from n/a through 4.9.1.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-114195.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit