Skip to content
Laskyr

Plugins · royal-mcp · data as of 2026-11-04

Is Royal MCP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.14)

As of 2026-11-04. 6 issues are on record for older versions; version 1.5.10 or newer fixes all of them that state a fix.

Latest version
1.5.14
Last updated
2026-11-02
Active installs
10,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

250+ MCP tools. OAuth 2.0 + WebMCP. Connect Claude, ChatGPT, Perplexity, Gemini or any MCP agent to your WordPress site. 100% self-hosted. — by Royal Plugins

What to do

  1. Update to the latest version (1.5.14). Anything older than 1.5.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get royal-mcp --field=version shows what you run; wp plugin update royal-mcp updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-111960 · published 2026-10-28

Missing authorization check in Royal MCP (1.4.38 up to (not including) 1.5.10)

Affected
1.4.38 up to (not including) 1.5.10
Fixed in
1.5.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Royal MCP WordPress plugin before 1.5.10 does not perform object-level or post-type authorisation checks in one of its search tools, allowing authenticated users such as a subscriber to disclose the title and content of non-public entries, including personal data stored by a companion Royal MCP WordPress plugin before 1.5.10.

NVD CVE-2026-111960WPScan advisory

low 3.8 CVE-2026-111961 · published 2026-10-28

Missing authorization check in Royal MCP (older than 1.5.10)

Affected
older than 1.5.10
Fixed in
1.5.10
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Royal MCP WordPress plugin before 1.5.10 does not perform an object-level permission check before duplicating a requested page, relying on a generic capability, which allows users with contributor-level access to read the full content of any private or draft page and to publish it without holding the publish capability.

NVD CVE-2026-111961WPScan advisory

high 7.5 CVE-2026-111958 · published 2026-10-22

Authentication bypass in Royal MCP (older than 1.5.7)

Affected
older than 1.5.7
Fixed in
1.5.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Royal MCP WordPress plugin before 1.5.7 does not limit a preview-link token to the single preview it was issued for, so any party that obtains a valid token is authenticated as the token's owning user, an administrator in the default configuration, across the entire REST API with no nonce, leading to full site takeover.

NVD CVE-2026-111958WPScan advisory

high 8.1 CVE-2026-10750 · published 2026-07-01

Security issue in Royal MCP (older than 1.4.26)

Affected
older than 1.4.26
Fixed in
1.4.26
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Royal MCP WordPress plugin before 1.4.26 does not perform capability checks on the majority of its MCP tools after token authentication, allowing authenticated users with a low-privileged role such as Subscriber to read private content, enumerate all users and their roles, and create, modify, or delete content owned by other users.

NVD CVE-2026-10750WPScan advisory

high 8.1 CVE-2026-54842 · published 2026-06-25

Missing authorization check in Royal MCP (1.4.25 and older)

Affected
1.4.25 and older
Fixed in
1.4.26
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Royal Plugins Royal MCP allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects Royal MCP: from n/a through 1.4.25.

NVD CVE-2026-54842Patchstack advisory

high 7.3 CVE-2026-40775 · published 2026-06-15

Missing authorization check in Royal MCP (1.4.2 and older)

Affected
1.4.2 and older
Fixed in
1.4.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in Royal MCP <= 1.4.2 versions.

NVD CVE-2026-40775Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Royal MCP vulnerability status badge
<a href="https://laskyr.com/plugins/royal-mcp"><img src="https://laskyr.com/plugins/royal-mcp/badge.svg" alt="Royal MCP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit