Skip to content
Laskyr

CVE-2026-111958: Royal MCP authentication bypass vulnerability

high 7.5 published 2026-10-22

Fixed in Royal MCP 1.5.7

Royal MCP older than 1.5.7 is affected by this authentication bypass issue. Sites on 1.5.7 or newer are not affected; the latest release is 1.5.14.

Affected versions
older than 1.5.7
Fixed in
1.5.7
Latest version
1.5.14
Severity
High · CVSS 7.5
Active installs
10,000+
Type
Authentication bypass

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

What to do now

  1. Update Royal MCP to 1.5.7 or newer (the latest is 1.5.14): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Royal MCP issue. With WP-CLI: wp plugin get royal-mcp --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Royal MCP WordPress plugin before 1.5.7 does not limit a preview-link token to the single preview it was issued for, so any party that obtains a valid token is authenticated as the token's owning user, an administrator in the default configuration, across the entire REST API with no nonce, leading to full site takeover.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-111958.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit