Skip to content
Laskyr

Plugins · real-time-auto-find-and-replace · data as of 2026-11-04

Is Better Find and Replace safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.1)

As of 2026-11-04. 8 issues are on record for older versions; version 1.8.0 or newer fixes all of them that state a fix.

Latest version
2.0.1
Last updated
2026-10-26
Active installs
40,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Search and replace text, images, URLs, footer credits, code blocks or jQuery-Ajax content in real time or in Database, easy user-interface — by CodeSolz

What to do

  1. Update to the latest version (2.0.1). Anything older than 1.8.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get real-time-auto-find-and-replace --field=version shows what you run; wp plugin update real-time-auto-find-and-replace updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-3369 · published 2026-04-16

Stored cross-site scripting (XSS) in Better Find and Replace (1.7.9 and older)

Affected
1.7.9 and older
Fixed in
1.8.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Better Find and Replace – AI-Powered Suggestions plugin for WordPress is vulnerable to Stored Cross-Site Scripting via uploaded image title in versions up to, and including, 1.7.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-3369Wordfence advisoryCode change (fix)

high 8.8 CVE-2025-9334 · published 2025-11-08

Remote code execution in Better Find and Replace (1.7.7 and older)

Affected
1.7.7 and older
Fixed in
1.7.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Better Find and Replace – AI-Powered Suggestions plugin for WordPress is vulnerable to Limited Code Injection in all versions up to, and including, 1.7.7. This is due to insufficient input validation and restriction on the 'rtafar_ajax' function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to call arbitrary plugin functions and execute code within those functions.

NVD CVE-2025-9334Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2025-12360 · published 2025-11-06

Missing authorization check in Better Find and Replace (1.7.7 and older)

Affected
1.7.7 and older
Fixed in
1.7.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Better Find and Replace – AI-Powered Suggestions plugin for WordPress is vulnerable to unauthorized API usage due to a missing capability check on the rtafar_ajax() function in all versions up to, and including, 1.7.7. This makes it possible for authenticated attackers, with Subscriber-level access, to trigger OpenAI API key usage resulting in quota consumption potentially incurring cost.

NVD CVE-2025-12360Wordfence advisoryCode change (fix)Plugin source

medium 5.9 CVE-2025-53466 · published 2025-09-22

Stored cross-site scripting (XSS) in Better Find and Replace (1.7.6 and older)

Affected
1.7.6 and older
Fixed in
1.7.7
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodeSolz Better Find and Replace real-time-auto-find-and-replace allows Stored XSS.This issue affects Better Find and Replace: from n/a through <= 1.7.6.

NVD CVE-2025-53466Patchstack advisory

high 8.8 CVE-2025-24734 · published 2025-01-27

Privilege escalation in Better Find and Replace (1.6.7 and older)

Affected
1.6.7 and older
Fixed in
1.6.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in CodeSolz Better Find and Replace real-time-auto-find-and-replace allows Privilege Escalation.This issue affects Better Find and Replace: from n/a through <= 1.6.7.

NVD CVE-2025-24734Patchstack advisory

high 8.3 CVE-2024-39636 · published 2024-08-01

PHP object injection in Better Find and Replace (1.6.1 and older)

Affected
1.6.1 and older
Fixed in
1.6.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in CodeSolz Better Find and Replace.This issue affects Better Find and Replace: from n/a through 1.6.1.

NVD CVE-2024-39636Patchstack advisory

high 7.2 CVE-2022-1472 · published 2022-06-20

SQL injection in Better Find and Replace (older than 1.3.6)

Affected
older than 1.3.6
Fixed in
1.3.6
Access needed (per CVSS)
Needs an admin-level account
Range from
advisory text · score by NVD
Details from the advisory

The Better Find and Replace WordPress plugin before 1.3.6 does not properly sanitise, validate and escape various parameters before using them in an SQL statement, leading to an SQL Injection

NVD CVE-2022-1472WPScan advisory

medium 6.1 CVE-2021-24676 · published 2021-10-04

Reflected cross-site scripting (XSS) in Better Find and Replace (older than 1.2.9)

Affected
older than 1.2.9
Fixed in
1.2.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The Better Find and Replace WordPress plugin before 1.2.9 does not escape the 's' GET parameter before outputting back in the All Masking Rules page, leading to a Reflected Cross-Site Scripting issue

NVD CVE-2021-24676WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Better Find and Replace vulnerability status badge
<a href="https://laskyr.com/plugins/real-time-auto-find-and-replace"><img src="https://laskyr.com/plugins/real-time-auto-find-and-replace/badge.svg" alt="Better Find and Replace vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit