Plugins · query-wrangler · data as of 2026-11-04
Is Query Wrangler safe? Known vulnerabilities and latest version
- Status
- Closed 2026-08-18
- Known issues on record
- 5
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate query-wrangler && wp plugin delete query-wrangler
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 5 record(s) do not state which versions are affected.
critical 9.9 CVE-2026-73992 · published 2026-08-20
Remote code execution in Query Wrangler (1.5.57 and older)
- Affected
- 1.5.57 and older
- Fixed in
- 1.5.58
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Remote Code Execution (RCE) in Query Wrangler <= 1.5.57 versions.
high 8.8 CVE-2026-14498 · published 2026-08-16
Remote code execution in Query Wrangler (1.5.57 and older)
- Affected
- 1.5.57 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Query Wrangler plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.5.57 via the 'options' parameter parameter. This is due to missing capability check and nonce verification on the wp_ajax_qw_form_ajax handler, combined with unsanitized attacker-controlled options fully replacing saved query options and being passed directly to call_user_func_array() guarded only by function_exists(). This makes it possible for authenticated attackers, with subscriber-level access and above, to execute code on the server. Exploitation requires only that at least one query row exists in the database, as the query_id is a small enumerable integer with no further access control.
NVD CVE-2026-14498Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2026-65491 · published 2026-07-23
Missing authorization check in Query Wrangler (1.5.57 and older)
- Affected
- 1.5.57 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Broken Access Control in Query Wrangler <= 1.5.57 versions.
medium 5.4 CVE-2025-31779 · published 2025-04-01
Cross-site request forgery (CSRF) in Query Wrangler (1.5.54 and older)
- Affected
- 1.5.54 and older
- Fixed in
- 1.5.55
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Jonathan Daggerhart Query Wrangler query-wrangler allows Cross Site Request Forgery.This issue affects Query Wrangler: from n/a through <= 1.5.54.
medium 6.1 CVE-2023-30779 · published 2023-08-16
Reflected cross-site scripting (XSS) in Query Wrangler (1.5.51 and older)
- Affected
- 1.5.51 and older
- Fixed in
- 1.5.52
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Jonathan Daggerhart Query Wrangler plugin <= 1.5.51 versions.
Recent activity
- 2026-08-18 — closed on wordpress.org (Author Request).
- 2026-08-20 — Remote code execution disclosed (CVE-2026-73992), fixed in 1.5.58.
- 2026-08-16 — Remote code execution disclosed (CVE-2026-14498), fix version not stated.
- 2026-07-23 — Missing authorization check disclosed (CVE-2026-65491), fix version not stated.
Get an email when Query Wrangler has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Query Wrangler (query-wrangler) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Remote code execution (2) · Missing authorization (1) · Cross-site request forgery (CSRF) (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/query-wrangler (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/query-wrangler"><img src="https://laskyr.com/plugins/query-wrangler/badge.svg" alt="Query Wrangler vulnerability status"></a>