Plugins · qa-heatmap-analytics · data as of 2026-11-04
Is QA Assistants safe? Known vulnerabilities and latest version
- Latest version
- 5.3.0.2
- Last updated
- 2026-10-22
- Active installs
- 2,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Let your data speak — assistants with different perspectives help you understand your site, alongside heatmaps and replays. — by QuarkA
What to do
- Update to the latest version (5.3.0.2). Anything older than 5.3.0.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get qa-heatmap-analytics --field=version shows what you run; wp plugin update qa-heatmap-analytics updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-114697 · published 2026-10-24
Stored cross-site scripting (XSS) in QA Assistants (5.3.0.1 and older)
- Affected
- 5.3.0.1 and older
- Fixed in
- 5.3.0.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in QuarkA QA Analytics qa-heatmap-analytics allows Stored XSS.This issue affects QA Analytics: from n/a through 5.3.0.1.
medium 6.9 CVE-2026-105877 · published 2026-10-09
Information disclosure in QA Assistants (5.3.0.0 and older)
- Affected
- 5.3.0.0 and older
- Fixed in
- 5.3.0.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Insertion of Sensitive Information Into Sent Data vulnerability in QuarkA QA Analytics qa-heatmap-analytics allows Retrieve Embedded Sensitive Data.This issue affects QA Analytics: from n/a through 5.3.0.0.
critical 10.0 CVE-2026-27544 · published 2026-08-13
Remote code execution in QA Assistants (5.2.0.0 and older)
- Affected
- 5.2.0.0 and older
- Fixed in
- 5.2.0.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Remote Code Execution (RCE) in QA Analytics <= 5.2.0.0 versions.
medium 5.3 CVE-2024-8513 · published 2024-10-10
Missing authorization check in QA Assistants (4.1.1.1 and older)
- Affected
- 4.1.1.1 and older
- Fixed in
- 4.1.2.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The QA Analytics – Web Analytics Tool with Heatmaps & Session Replay Across All Pages plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the ajax_save_plugin_config() function in all versions up to, and including, 4.1.1.1. This makes it possible for unauthenticated attackers to update the plugin's settings.
NVD CVE-2024-8513Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-22 — latest release on wordpress.org (5.3.0.2).
- 2026-10-24 — Stored cross-site scripting (XSS) disclosed (CVE-2026-114697), fixed in 5.3.0.2.
- 2026-10-09 — Information disclosure disclosed (CVE-2026-105877), fixed in 5.3.0.1.
- 2026-08-13 — Remote code execution disclosed (CVE-2026-27544), fixed in 5.2.0.1.
Get an email when QA Assistants has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for QA Assistants (qa-heatmap-analytics) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Sensitive data exposure (1) · Remote code execution (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/qa-heatmap-analytics (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/qa-heatmap-analytics"><img src="https://laskyr.com/plugins/qa-heatmap-analytics/badge.svg" alt="QA Assistants vulnerability status"></a>