Skip to content
Laskyr

Plugins · player-leaderboard · data as of 2026-11-04

Is Player Leaderboard safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.3 or newer fixes all of them that state a fix.

Latest version
1.1
Last updated
2026-07-21
Active installs
30+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Manage sports competitions, players and results, then publish standings, rankings and duel matrices with a shortcode. — by tharkun69

What to do

  1. Update to the latest version (1.1). Anything older than 1.0.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get player-leaderboard --field=version shows what you run; wp plugin update player-leaderboard updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2025-12824 · published 2025-12-12

Remote code execution in Player Leaderboard (1.0.0 to 1.0.2)

Affected
1.0.0 to 1.0.2
Fixed in
1.0.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Player Leaderboard plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 1.0.2 via the 'player_leaderboard' shortcode. This is due to the plugin using an unsanitized user-supplied value from the shortcode's 'mode' attribute in a call to include() without proper path validation. This makes it possible for authenticated attackers, with Contributor-level access and above, to include and execute arbitrary PHP files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve full remote code execution if combined with file upload capabilities.

NVD CVE-2025-12824Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Player Leaderboard vulnerability status badge
<a href="https://laskyr.com/plugins/player-leaderboard"><img src="https://laskyr.com/plugins/player-leaderboard/badge.svg" alt="Player Leaderboard vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit