Plugins · opti-behavior · data as of 2026-11-04
Is Opti-Behavior safe? Known vulnerabilities and latest version
- Latest version
- 1.10.1
- Last updated
- 2026-10-27
- Active installs
- 2,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Self-hosted click heatmaps, click tracking and funnels for WordPress and WooCommerce. Analytics data is stored on your server. Session replay in Pro. — by OptiUser
What to do
- Update to the latest version (1.10.1). Anything older than 1.10.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get opti-behavior --field=version shows what you run; wp plugin update opti-behavior updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-95809 · published 2026-10-16
DOM-based cross-site scripting (XSS) in Opti-Behavior (1.9.2.1 and older)
- Affected
- 1.9.2.1 and older
- Fixed in
- 1.10.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Opti-Behavior – Self-Hosted Heatmaps, Session Recordings, Funnels, A/B Testing & Smart Insights plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via 'country_name' Location Parameter in all versions up to, and including, 1.9.2.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The heatmap recording endpoint accepts unauthenticated requests protected only by a nonce that any visitor can freely obtain via the public opti_behavior_refresh_nonces AJAX action, removing any practical barrier to injecting the malicious payload.
NVD CVE-2026-95809Wordfence advisoryCode change (fix)plugins.svn.wordpress.orgPlugin source
high 7.2 CVE-2026-95686 · published 2026-10-16
DOM-based cross-site scripting (XSS) in Opti-Behavior (1.9.2.1 and older)
- Affected
- 1.9.2.1 and older
- Fixed in
- 1.10.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Opti-Behavior – Self-Hosted Heatmaps, Session Recordings, Funnels, A/B Testing & Smart Insights plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'targetUrl' parameter in all versions up to, and including, 1.9.2.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The ingest endpoint is gated only by a nonce that is publicly emitted to every anonymous visitor on tracked pages via optiBehaviorHeatmapConfig.nonce, meaning no account or authentication of any kind is required to write the malicious payload.
NVD CVE-2026-95686Wordfence advisoryCode change (fix)plugins.svn.wordpress.orgPlugin source
Recent activity
- 2026-10-27 — latest release on wordpress.org (1.10.1).
- 2026-10-16 — DOM-based cross-site scripting (XSS) disclosed (CVE-2026-95809), fixed in 1.10.0.
- 2026-10-16 — DOM-based cross-site scripting (XSS) disclosed (CVE-2026-95686), fixed in 1.10.0.
Get an email when Opti-Behavior has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Opti-Behavior (opti-behavior) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/opti-behavior (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/opti-behavior"><img src="https://laskyr.com/plugins/opti-behavior/badge.svg" alt="Opti-Behavior vulnerability status"></a>