Skip to content
Laskyr

CVE-2026-95809: Opti-Behavior DOM-based cross-site scripting (XSS) vulnerability

high 7.2 published 2026-10-16

Fixed in Opti-Behavior 1.10.0 (first release after the affected range)

Opti-Behavior 1.9.2.1 and older is affected by this DOM-based XSS issue. Sites on 1.10.0 or newer are not affected; the latest release is 1.10.1.

Affected versions
1.9.2.1 and older
Fixed in
1.10.0 *
Latest version
1.10.1
Severity
High · CVSS 7.2
Active installs
2,000+
Type
DOM-based cross-site scripting (XSS)

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

What to do now

  1. Update Opti-Behavior to 1.10.0 or newer (the latest is 1.10.1): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Opti-Behavior issue. With WP-CLI: wp plugin get opti-behavior --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Opti-Behavior – Self-Hosted Heatmaps, Session Recordings, Funnels, A/B Testing & Smart Insights plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via 'country_name' Location Parameter in all versions up to, and including, 1.9.2.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The heatmap recording endpoint accepts unauthenticated requests protected only by a nonce that any visitor can freely obtain via the public opti_behavior_refresh_nonces AJAX action, removing any practical barrier to injecting the malicious payload.

Description from the CVE record, published by Wordfence (the CVE Numbering Authority), via the NVD entry for CVE-2026-95809.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit