Plugins · nitropack · data as of 2026-11-04
Is NitroPack safe? Known vulnerabilities and latest version
- Latest version
- 1.20.3
- Last updated
- 2026-09-25
- Active installs
- 80,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Boost site speed and performance with an all-in-one cache and speed optimization plugin. Pass Core Web Vitals with CDN, image optimization, lazy loadi … — by NitroPack
What to do
- Update to the latest version (1.20.3). Anything older than 1.19.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get nitropack --field=version shows what you run; wp plugin update nitropack updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-39669 · published 2026-04-08
Missing authorization check in NitroPack (1.19.3 and older)
- Affected
- 1.19.3 and older
- Fixed in
- 1.19.4
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in NitroPack allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects NitroPack: from n/a through 1.19.3.
medium 4.3 CVE-2025-8778 · published 2025-09-10
Missing authorization check in NitroPack (1.18.4 and older)
- Affected
- 1.18.4 and older
- Fixed in
- 1.18.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The NitroPack plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the nitropack_set_compression_ajax() function in all versions up to, and including, 1.18.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update the nitropack-enableCompression option and effectively change plugin compression settings.
NVD CVE-2025-8778Wordfence advisoryCode change (fix)wordpress.orgPlugin source
high 8.1 CVE-2024-11848 · published 2025-01-15
Missing authorization check in NitroPack (1.17.0 and older)
- Affected
- 1.17.0 and older
- Fixed in
- 1.17.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The NitroPack plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'nitropack_dismiss_notice_forever' AJAX action in all versions up to, and including, 1.17.0. This makes it possible for authenticated attackers, with subscriber-level access and above, to update arbitrary options to a fixed value of '1' which can activate certain options (e.g., enable user registration) or modify certain options in a way that leads to a denial of service condition.
medium 4.3 CVE-2024-11851 · published 2025-01-15
Missing authorization check in NitroPack (1.17.0 and older)
- Affected
- 1.17.0 and older
- Fixed in
- 1.17.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The NitroPack plugin for WordPress is vulnerable to unauthorized arbitrary transient update due to a missing capability check on the nitropack_rml_notification function in all versions up to, and including, 1.17.0. This makes it possible for authenticated attackers, with subscriber access or higher, to update arbitrary transients. Note, that these transients can only be updated to integers and not arbitrary values.
critical 9.8 CVE-2024-43922 · published 2024-08-29
Remote code execution in NitroPack (1.16.7 and older)
- Affected
- 1.16.7 and older
- Fixed in
- 1.16.8
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Control of Generation of Code ('Code Injection') vulnerability in NitroPack Inc. NitroPack allows Code Injection.This issue affects NitroPack: from n/a through 1.16.7.
high 8.8 CVE-2023-52121 · published 2024-01-05
Cross-site request forgery (CSRF) in NitroPack (1.10.2 and older)
- Affected
- 1.10.2 and older
- Fixed in
- 1.10.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in NitroPack Inc. NitroPack – Cache & Speed Optimization for Core Web Vitals, Defer CSS & JavaScript, Lazy load Images.This issue affects NitroPack – Cache & Speed Optimization for Core Web Vitals, Defer CSS & JavaScript, Lazy load Images: from n/a through 1.10.2.
Recent activity
- 2026-09-25 — latest release on wordpress.org (1.20.3).
- 2026-04-08 — Missing authorization check disclosed (CVE-2026-39669), fixed in 1.19.4.
- 2025-09-10 — Missing authorization check disclosed (CVE-2025-8778), fixed in 1.18.5.
- 2025-01-15 — Missing authorization check disclosed (CVE-2024-11848), fixed in 1.17.6.
Get an email when NitroPack has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for NitroPack (nitropack) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (4) · Remote code execution (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/nitropack (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/nitropack"><img src="https://laskyr.com/plugins/nitropack/badge.svg" alt="NitroPack vulnerability status"></a>