Plugins · nexter-extension · data as of 2026-11-04
Is Nexter Extension safe? Known vulnerabilities and latest version
- Latest version
- 4.8.1
- Last updated
- 2026-10-29
- Active installs
- 10,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Replace 50+ WordPress Plugins: Free SEO, Theme Builder, Code Snippets, Image Optimizer (WebP/AVIF), SMTP Email, Security, Performance & More — by POSIMYTH
What to do
- Update to the latest version (4.8.1). Anything older than 4.7.12 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get nexter-extension --field=version shows what you run; wp plugin update nexter-extension updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-111114 · published 2026-10-16
Privilege escalation in Nexter Extension (4.7.11 and older)
- Affected
- 4.7.11 and older
- Fixed in
- 4.7.12 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Nexter Extension – Security, Performance, Code Snippets & Site Toolkit plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 4.7.11 The vulnerability exists because the `/?reset-view` handler in `role_switcher_to_view_admin_as()` performs no nonce or capability check when the supplied username matches the authenticated caller, and because the plugin's only cleanup mechanism — the `profile_update` hook — does not fire when WordPress performs a bulk role change via `wp-admin/users.php?action=promote`, which calls `WP_User::set_role()` directly and leaves a stale `administrator` value in the `nxtext_view_admin_original_role` user meta. This makes it possible for authenticated attackers with Subscriber-level access or above to restore the stale stored Administrator role to their own account, effectively escalating their privileges to Administrator. Exploitation requires that the attacker's account previously held the Administrator role and used the View Admin Role Switcher feature before being demoted specifically through the bulk role-change control rather than the Edit User screen, as only the bulk path bypasses the `profile_update` hook that would otherwise have cleared the stored original role.
NVD CVE-2026-111114Wordfence advisoryCode change (fix)Plugin source
high 8.1 CVE-2026-0726 · published 2026-01-20
PHP object injection in Nexter Extension (4.4.6 and older)
- Affected
- 4.4.6 and older
- Fixed in
- 4.4.7 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Nexter Extension – Site Enhancements Toolkit plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 4.4.6 via deserialization of untrusted input in the 'nxt_unserialize_replace' function. This makes it possible for unauthenticated attackers to inject a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present.
medium 6.4 CVE-2025-13731 · published 2025-12-02
Stored cross-site scripting (XSS) in Nexter Extension (4.4.1 and older)
- Affected
- 4.4.1 and older
- Fixed in
- 4.4.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Nexter Extension – Site Enhancements Toolkit plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'nxt-year' shortcode in all versions up to, and including, 4.4.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-13731Wordfence advisoryCode change (fix)Plugin source
high 7.2 CVE-2023-45751 · published 2023-12-29
Remote code execution in Nexter Extension (2.0.3 and older)
- Affected
- 2.0.3 and older
- Fixed in
- 2.0.4
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Control of Generation of Code ('Code Injection') vulnerability in POSIMYTH Nexter Extension.This issue affects Nexter Extension: from n/a through 2.0.3.
medium 6.1 CVE-2023-45750 · published 2023-10-25
Reflected cross-site scripting (XSS) in Nexter Extension (2.0.3 and older)
- Affected
- 2.0.3 and older
- Fixed in
- 2.0.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in POSIMYTH Nexter Extension plugin <= 2.0.3 versions.
Recent activity
- 2026-10-29 — latest release on wordpress.org (4.8.1).
- 2026-10-16 — Privilege escalation disclosed (CVE-2026-111114), fixed in 4.7.12.
- 2026-01-20 — PHP object injection disclosed (CVE-2026-0726), fixed in 4.4.7.
- 2025-12-02 — Stored cross-site scripting (XSS) disclosed (CVE-2025-13731), fixed in 4.4.2.
Get an email when Nexter Extension has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Nexter Extension (nexter-extension) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by POSIMYTH (5 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Privilege escalation (1) · PHP object injection (1) · Remote code execution (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/nexter-extension (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/nexter-extension"><img src="https://laskyr.com/plugins/nexter-extension/badge.svg" alt="Nexter Extension vulnerability status"></a>