Skip to content
Laskyr

Plugins · nelio-ab-testing · data as of 2026-11-04

Is Nelio A/B Testing safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (8.5.7)

As of 2026-11-04. 8 issues are on record for older versions; version 8.3.0 or newer fixes all of them that state a fix.

Latest version
8.5.7
Last updated
2026-10-26
Active installs
4,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Run A/B tests and heatmaps in WordPress. Optimize pages and WooCommerce products, track conversions, and start free with 500 tested views/month. — by Nelio Software

What to do

  1. Update to the latest version (8.5.7). Anything older than 8.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get nelio-ab-testing --field=version shows what you run; wp plugin update nelio-ab-testing updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-40742 · published 2026-04-15

Missing authorization check in Nelio A/B Testing (8.2.8 and older)

Affected
8.2.8 and older
Fixed in
8.3.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Nelio Software Nelio AB Testing nelio-ab-testing allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Nelio AB Testing: from n/a through <= 8.2.8.

NVD CVE-2026-40742Patchstack advisory

critical 9.1 CVE-2026-32573 · published 2026-03-25

Remote code execution in Nelio A/B Testing (8.2.7 and older)

Affected
8.2.7 and older
Fixed in
8.2.8
Access needed (per CVSS)
Needs an admin-level account
Range from
advisory text · score by Patchstack
Details from the advisory

Improper Control of Generation of Code ('Code Injection') vulnerability in Nelio Software Nelio AB Testing nelio-ab-testing allows Code Injection.This issue affects Nelio AB Testing: from n/a through <= 8.2.7.

NVD CVE-2026-32573Patchstack advisory

high 7.6 CVE-2026-25378 · published 2026-02-19

SQL injection in Nelio A/B Testing (8.2.4 and older)

Affected
8.2.4 and older
Fixed in
8.2.5
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Nelio Software Nelio AB Testing nelio-ab-testing allows Blind SQL Injection.This issue affects Nelio AB Testing: from n/a through <= 8.2.4.

NVD CVE-2026-25378Patchstack advisory

critical 9.1 CVE-2025-67944 · published 2026-01-22

Remote code execution in Nelio A/B Testing (8.1.8 and older)

Affected
8.1.8 and older
Fixed in
8.2.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Generation of Code ('Code Injection') vulnerability in Nelio Software Nelio AB Testing nelio-ab-testing allows Code Injection.This issue affects Nelio AB Testing: from n/a through <= 8.1.8.

NVD CVE-2025-67944Patchstack advisory

medium 6.5 CVE-2016-10977 · published 2019-09-17

Path traversal / file read in Nelio A/B Testing (older than 4.5.0)

Affected
older than 4.5.0
Fixed in
4.5.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
NVD analysis · score by NVD
Details from the advisory

The nelio-ab-testing plugin before 4.5.0 for WordPress has filename=..%2f directory traversal.

NVD CVE-2016-10977wordpress.orgwpvulndb.comopenwall.com

critical 10.0 CVE-2016-10926 · published 2019-08-22

Server-side request forgery (SSRF) in Nelio A/B Testing (older than 4.5.9)

Affected
older than 4.5.9
Fixed in
4.5.9
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The nelio-ab-testing plugin before 4.5.9 for WordPress has SSRF in ajax/iesupport.php.

NVD CVE-2016-10926wordpress.org

critical 10.0 CVE-2016-10927 · published 2019-08-22

Server-side request forgery (SSRF) in Nelio A/B Testing (older than 4.5.11)

Affected
older than 4.5.11
Fixed in
4.5.11
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The nelio-ab-testing plugin before 4.5.11 for WordPress has SSRF in ajax/iesupport.php.

NVD CVE-2016-10927wordpress.org

high 8.8 CVE-2017-18547 · published 2019-08-16

Cross-site request forgery (CSRF) in Nelio A/B Testing (older than 4.6.4)

Affected
older than 4.6.4
Fixed in
4.6.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The nelio-ab-testing plugin before 4.6.4 for WordPress has CSRF in experiment forms.

NVD CVE-2017-18547wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Nelio A/B Testing vulnerability status badge
<a href="https://laskyr.com/plugins/nelio-ab-testing"><img src="https://laskyr.com/plugins/nelio-ab-testing/badge.svg" alt="Nelio A/B Testing vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit