Skip to content
Laskyr

Plugins · modal-dialog · data as of 2026-11-04

Is Modal Dialog safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.5.17)

As of 2026-11-04. 3 issues are on record for older versions; version 3.5.17 or newer fixes all of them that state a fix.

Latest version
3.5.17
Last updated
2026-02-15
Active installs
500+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
6.9.11

The purpose of this plugin is to allow users to create one or more modal dialog(s) / pop-up window(s) that will appear when a user visits their site. — by Yannick Lefebvre

What to do

  1. Update to the latest version (3.5.17). Anything older than 3.5.17 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get modal-dialog --field=version shows what you run; wp plugin update modal-dialog updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.1 CVE-2026-32367 · published 2026-03-13

Remote code execution in Modal Dialog (3.5.16 and older)

Affected
3.5.16 and older
Fixed in
3.5.17
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Generation of Code ('Code Injection') vulnerability in Yannick Lefebvre Modal Dialog modal-dialog allows Remote Code Inclusion.This issue affects Modal Dialog: from n/a through <= 3.5.16.

NVD CVE-2026-32367Patchstack advisory

medium 6.1 CVE-2023-31071 · published 2023-08-17

Reflected cross-site scripting (XSS) in Modal Dialog (3.5.14 and older)

Affected
3.5.14 and older
Fixed in
3.5.15
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Yannick Lefebvre Modal Dialog plugin <= 3.5.14 versions.

NVD CVE-2023-31071Patchstack advisory

medium 4.8 CVE-2023-24001 · published 2023-04-06

Stored cross-site scripting (XSS) in Modal Dialog (3.5.9 and older)

Affected
3.5.9 and older
Fixed in
3.5.10
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Yannick Lefebvre Modal Dialog plugin <= 3.5.9 versions.

NVD CVE-2023-24001Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Modal Dialog vulnerability status badge
<a href="https://laskyr.com/plugins/modal-dialog"><img src="https://laskyr.com/plugins/modal-dialog/badge.svg" alt="Modal Dialog vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit