Plugins · membership-for-woocommerce · data as of 2026-11-04
Is Membership For WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 3.1.3
- Last updated
- 2026-10-30
- Active installs
- 800+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
The membership plugin lets you easily restrict content, build online communities, customize user roles, & quickly manage access permissions. — by WP Swings
What to do
- Update to the latest version (3.1.3). Anything older than 3.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get membership-for-woocommerce --field=version shows what you run; wp plugin update membership-for-woocommerce updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-19709 · published 2026-08-19
Authentication bypass in Membership For WooCommerce (older than 3.1.2)
- Affected
- older than 3.1.2
- Fixed in
- 3.1.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Membership For WooCommerce WordPress plugin before 3.1.2 does not check that an API consumer secret has actually been generated before comparing it against the one supplied in a request, allowing unauthenticated attackers to reach its REST routes and disclose any user's membership plan details on sites where the API has been enabled but no keys were ever generated.
high 8.6 CVE-2026-57709 · published 2026-07-13
Path traversal / file read in Membership For WooCommerce (3.1.0 and older)
- Affected
- 3.1.0 and older
- Fixed in
- 3.1.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in WP Swings Membership For WooCommerce membership-for-woocommerce allows Path Traversal.This issue affects Membership For WooCommerce: from n/a through <= 3.1.0.
high 7.5 CVE-2025-67909 · published 2025-12-24
Missing authorization check in Membership For WooCommerce (3.0.3 and older)
- Affected
- 3.0.3 and older
- Fixed in
- 3.0.4
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Authorization Bypass Through User-Controlled Key vulnerability in WP Swings Membership For WooCommerce membership-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Membership For WooCommerce: from n/a through <= 3.0.3.
high 7.5 CVE-2025-54692 · published 2025-08-14
Missing authorization check in Membership For WooCommerce (2.9.0 and older)
- Affected
- 2.9.0 and older
- Fixed in
- 3.0.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WP Swings Membership For WooCommerce membership-for-woocommerce allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Membership For WooCommerce: from n/a through <= 2.9.0.
high 7.5 CVE-2025-49265 · published 2025-06-09
Missing authorization check in Membership For WooCommerce (2.8.1 and older)
- Affected
- 2.8.1 and older
- Fixed in
- 2.8.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WP Swings Membership For WooCommerce membership-for-woocommerce allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Membership For WooCommerce: from n/a through <= 2.8.1.
medium 6.5 CVE-2025-39579 · published 2025-04-16
Cross-site scripting (XSS) in Membership For WooCommerce (2.8.0 and older)
- Affected
- 2.8.0 and older
- Fixed in
- 2.8.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Swings Membership For WooCommerce membership-for-woocommerce allows DOM-Based XSS.This issue affects Membership For WooCommerce: from n/a through <= 2.8.0.
critical 9.8 CVE-2022-4395 · published 2023-01-30
Remote code execution in Membership For WooCommerce (older than 2.1.7)
- Affected
- older than 2.1.7
- Fixed in
- 2.1.7
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Membership For WooCommerce WordPress plugin before 2.1.7 does not validate uploaded files, which could allow unauthenticated users to upload arbitrary files, such as malicious PHP code, and achieve RCE.
NVD CVE-2022-4395WPScan advisorypacketstormsecurity.comexploit-db.com
Recent activity
- 2026-10-30 — latest release on wordpress.org (3.1.3).
- 2026-08-19 — Authentication bypass disclosed (CVE-2026-19709), fixed in 3.1.2.
- 2026-07-13 — Path traversal / file read disclosed (CVE-2026-57709), fixed in 3.1.1.
- 2025-12-24 — Missing authorization check disclosed (CVE-2025-67909), fixed in 3.0.4.
Get an email when Membership For WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Membership For WooCommerce (membership-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by WP Swings (9 tracked)
Types found in this plugin: Missing authorization (3) · Authentication bypass (1) · Path traversal and file read (1) · Cross-site scripting (XSS) (1) · Remote code execution (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/membership-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/membership-for-woocommerce"><img src="https://laskyr.com/plugins/membership-for-woocommerce/badge.svg" alt="Membership For WooCommerce vulnerability status"></a>