Plugins · mailjet-for-wordpress · data as of 2026-11-04
Is Mailjet Email Marketing safe? Known vulnerabilities and latest version
- Latest version
- 6.2.4
- Last updated
- 2026-10-14
- Active installs
- 10,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Includes WooCommerce automated and order emails. Design, send and track engaging marketing and transactional emails from your WordPress admin. — by Mailjet
What to do
- Update to the latest version (6.2.4). Anything older than 6.2.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get mailjet-for-wordpress --field=version shows what you run; wp plugin update mailjet-for-wordpress updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-39791 · published 2026-10-06
Information disclosure in Mailjet Email Marketing (6.2.3 and older)
- Affected
- 6.2.3 and older
- Fixed in
- 6.2.4 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Sensitive Data Exposure in Mailjet Email Marketing <= 6.2.3 versions.
Recent activity
- 2026-10-14 — latest release on wordpress.org (6.2.4).
- 2026-10-06 — Information disclosure disclosed (CVE-2026-39791), fixed in 6.2.4.
Get an email when Mailjet Email Marketing has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Mailjet Email Marketing (mailjet-for-wordpress) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/mailjet-for-wordpress (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/mailjet-for-wordpress"><img src="https://laskyr.com/plugins/mailjet-for-wordpress/badge.svg" alt="Mailjet Email Marketing vulnerability status"></a>