Skip to content
Laskyr

CVE-2026-39791: Mailjet Email Marketing information disclosure vulnerability

medium 5.3 published 2026-10-06

Fixed in Mailjet Email Marketing 6.2.4 (first release after the affected range)

Mailjet Email Marketing 6.2.3 and older is affected by this information disclosure issue. Sites on 6.2.4 or newer are not affected; the latest release is 6.2.4.

Affected versions
6.2.3 and older
Fixed in
6.2.4 *
Latest version
6.2.4
Severity
Medium · CVSS 5.3
Active installs
10,000+
Type
Information disclosure

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

What to do now

  1. Update Mailjet Email Marketing to 6.2.4 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Mailjet Email Marketing issue. With WP-CLI: wp plugin get mailjet-for-wordpress --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Unauthenticated Sensitive Data Exposure in Mailjet Email Marketing <= 6.2.3 versions.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-39791.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit