Skip to content
Laskyr

Plugins · likebtn-like-button · data as of 2026-11-04

Is Like Button Rating ♥ LikeBtn safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.6.65)

As of 2026-11-04. 6 issues are on record for older versions; version 2.6.65 or newer fixes all of them that state a fix.

Latest version
2.6.65
Last updated
2026-10-29
Active installs
3,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4

Add Like button to posts, pages, comments, WooCommerce, BuddyPress, bbPress, UM, custom posts! Sort content by likes! Get instant stats and insights! — by LikeBtn

What to do

  1. Update to the latest version (2.6.65). Anything older than 2.6.65 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get likebtn-like-button --field=version shows what you run; wp plugin update likebtn-like-button updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.7 CVE-2026-116552 · published 2026-10-30

Stored cross-site scripting (XSS) in Like Button Rating ♥ LikeBtn (2.6.64 and older)

Affected
2.6.64 and older
Fixed in
2.6.65 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Like Button Rating ♥ LikeBtn plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'HTTP_CLIENT_IP (Client-IP header)' parameter in all versions up to, and including, 2.6.64 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires the site administrator to have disabled the default 'Be GDPR compliant' option, which would otherwise hash stored IP values and neutralize the payload. Successful exploitation additionally requires an action by an administrator — the attacker cannot trigger the vulnerability on their own.

NVD CVE-2026-116552Wordfence advisoryCode change (fix)Plugin source

high 8.5 CVE-2026-78285 · published 2026-08-27

SQL injection in Like Button Rating ♥ LikeBtn (2.6.61 and older)

Affected
2.6.61 and older
Fixed in
2.6.62
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber SQL Injection in Like Button Rating <= 2.6.61 versions.

NVD CVE-2026-78285Patchstack advisory

medium 6.1 CVE-2024-44064 · published 2024-09-17

Cross-site scripting (XSS) in Like Button Rating ♥ LikeBtn (2.6.53 and older)

Affected
2.6.53 and older
Fixed in
2.6.54
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in LikeBtn Like Button Rating likebtn-like-button.This issue affects Like Button Rating: from n/a through <= 2.6.53.

NVD CVE-2024-44064Patchstack advisory

medium 6.5 CVE-2022-0745 · published 2022-06-13

Missing authorization check in Like Button Rating ♥ LikeBtn (older than 2.6.45)

Affected
older than 2.6.45
Fixed in
2.6.45
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
advisory text · score by NVD
Details from the advisory

The Like Button Rating WordPress plugin before 2.6.45 allows any logged-in user, such as subscriber, to send arbitrary e-mails to any recipient, with any subject and body

NVD CVE-2022-0745WPScan advisory

high 8.0 CVE-2021-24945 · published 2021-12-13

Cross-site request forgery (CSRF) in Like Button Rating ♥ LikeBtn (older than 2.6.38)

Affected
older than 2.6.38
Fixed in
2.6.38
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The Like Button Rating ♥ LikeBtn WordPress plugin before 2.6.38 does not have any authorisation and CSRF checks in the likebtn_export_votes AJAX action, which could allow any authenticated user, such as subscriber, to get a list of email and IP addresses of people who liked content from the blog.

NVD CVE-2021-24945WPScan advisory

high 7.5 CVE-2021-24150 · published 2021-04-05

Server-side request forgery (SSRF) in Like Button Rating ♥ LikeBtn (older than 2.6.32)

Affected
older than 2.6.32
Fixed in
2.6.32
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The LikeBtn WordPress Like Button Rating ♥ LikeBtn WordPress plugin before 2.6.32 was vulnerable to Unauthenticated Full-Read Server-Side Request Forgery (SSRF).

NVD CVE-2021-24150WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Like Button Rating ♥ LikeBtn vulnerability status badge
<a href="https://laskyr.com/plugins/likebtn-like-button"><img src="https://laskyr.com/plugins/likebtn-like-button/badge.svg" alt="Like Button Rating ♥ LikeBtn vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit