Skip to content
Laskyr

CVE-2026-116552: Like Button Rating ♥ LikeBtn stored cross-site scripting (XSS) vulnerability

medium 4.7 published 2026-10-30

Fixed in Like Button Rating ♥ LikeBtn 2.6.65 (first release after the affected range)

Like Button Rating ♥ LikeBtn 2.6.64 and older is affected by this stored XSS issue. Sites on 2.6.65 or newer are not affected; the latest release is 2.6.65.

Affected versions
2.6.64 and older
Fixed in
2.6.65 *
Latest version
2.6.65
Severity
Medium · CVSS 4.7
Active installs
3,000+
Type
Stored cross-site scripting (XSS)

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N

What to do now

  1. Update Like Button Rating ♥ LikeBtn to 2.6.65 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Like Button Rating ♥ LikeBtn issue. With WP-CLI: wp plugin get likebtn-like-button --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Like Button Rating ♥ LikeBtn plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'HTTP_CLIENT_IP (Client-IP header)' parameter in all versions up to, and including, 2.6.64 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires the site administrator to have disabled the default 'Be GDPR compliant' option, which would otherwise hash stored IP values and neutralize the payload. Successful exploitation additionally requires an action by an administrator — the attacker cannot trigger the vulnerability on their own.

Description from the CVE record, published by Wordfence (the CVE Numbering Authority), via the NVD entry for CVE-2026-116552.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit